Not able to get Xiaomi Gateway Key

xiaomi
Tags: #<Tag:0x00007f1ba6155248>

#1

Hi there,

I’ve been trying to get the key and token for my xiaomi AC gateway (the v3 one), but I’m not able to do it.

I’ve my Mi Home configured to China Mainland and English, I enter into the gateway screen, click on the three dots on the top right… and there is no “About” button.

Maybe I’m missing something? I was able to do it in the past with another xiaomi AC gateway (same model), but now I´m not :S. I’m using android.

Thanks…


#2

I’ve also tried it today with an iPhone and same, the “About” button is not present either… :S

Regards


#3

did you ever find a fix? I’m having the same problem, no about option whatever I do.


#4

No, I’ve asked the same in more forums, but I have no solution yet :frowning:

Cheers


#5

If you have access to an Android phone, you can download a hacked APK for the MiHome app that shows the hidden token of all items you have synced with the app. It’s in the network

I have used it to get the token for WiFi switches and vacuum, it works very well. Link to the apk can be found on this link.


#7

Thank you for the tip, unfortunatly the result from the MiToolkit does not give me the correct gateway key
It gives me a token for my airconditioning controller (wich is also the gateway) but that token is too long to be the key (should be 16 characters)

lumi.sensor_switch.aq2 - Aqara Wireless Mini Switch - -
yeelink.light.color1 - Yeelight Color Bulb - ff317f87f58409a82a97f0c0980d672f - 192.168.0.10
lumi.acpartner.v3 - Air Conditioning Controller(Advanced) - a731542760fe23f9b5da6d1f7d3d662a - 192.168.0.9
lumi.weather.v1 - Temperature and Humidity Sensor - -


#8

I was unable to get it to work with an iPhone. It does work on an Android. These instructions aren’t perfect, but they were good enough for me to make it work.

https://www.domoticz.com/wiki/Xiaomi_Gateway_(Aqara)#Adding_the_Xiaomi_Gateway_to_Domoticz


#9

Did you try the key you got for the aircon, You have a newer gateway, so the docs maybe incorrect in saying its 16 charachters


#10

The problem OP and I have is that we never get the “version” option in the menu so we can’t enter developer mode on the mihome app.


#11

I have, the config gives me an error saying it must be 16 characters :confused:


#12

A while back there was a linux script which is listing all the tokens … I saw it in context with the vacuum … unfortunately I dont have the link anymore.


#13

@leendert, I would suggest completely removing all traces of the MiHome app by going through settings, apps, and then force stopping, uninstalling and clearing the cache. Once that is done, reboot, and install the hacked version of the MiHome app and try again.

I have no issues seeing the “about” option in this version of app. Once in About, tap on the version number on the bottom of that screen until you get “hub info” pop up. Click on “hub info”, it will most likely be in Chinese, but you want to select the left button option when it pops up, this will take you to the page which shows the 16 character key.

I hope this works for you.


#14

It was a good idea but unfortunatly it didn’t change anything, tried installing the app on a different phone aswell


#15

I was able to get the key using an iPhone backup (or at least, I think I had success… I got the key but I wasn’t able to test it yet). Not all the tools mentioned in the page worked for me, but I was able to sort it out looking for other tools (as the SQLite reader)

Thanks!

Regards


#16

Sorry for my english but I speak only italian. Open you Gateway from Mi Home. Click on tre point at top, on the right, then click “About”. At the bottom of the page there’s a text similar this: “Plug-in version: 2.xx.x”.
Ok, you must to click some times this text, and next appears the menu that you are looking for


#17

Hi All,

Is there anyone who resolve the problem with Aqara gateway key please??? I don’t really know how resolve this. I think I tried everythink :grinning:. I tried find the item “about” in Aqara Home app but there isn’t it. So I connected Aqara gateway to Mi Home app vis HomeKit from iPhone app but again there isn’t “about” item :disappointed:. So do you know anybody how I find key for Aqara gateway plesse??? I need the key for connect to Home Assistant.

Thank you so much for answers.

Meny regards from Czech Republic,

Petr.

PS: I sorry for my English. I hope you understand my problem.


#18

Could use help retrieving the key as well.
Also cannot find the hacked home app version. Help is much appreciated


#19

Hello,

there is hacked Mi Home app

but this app show you only network token and mac address but no key

if you have any idea how to get key from hacked app please let me know.


#20

Yep, used the hacked home app as described above but just got a 32 character token… Been searching for days now to get the key from my camera hub to use it with home assistant.

Can anyone please help?


#21

The only way I got it working was to use an Android device.