Not able to read haCtx = global.get("homeassistant")

Today I switched from nodered as addon to nodered as a docker under unraid.
At the addon I was able to read states using:

If I run this node I do receive hactx is undefined?
So I guess that "homeassistant is not right.
What do I need to fill in for homeassistant?
I tried http://myHA_IP:8123 what is mentioned at the server settings, but also no results.
If I check the Global variables there is no homeassistant?

Do I need to set something in settings file or so?
I’m confused

When not running HA as addon, you will need to change the settings on the HA server config node.

This needs - using the HA add on as unticked
The base URL as - http://myHA_IP:8123
An access token - this is the authorisation token required to enable Node-RED HA server to connect back to HA using API/Websocket

The long-term access tokens are generated from within your user profile in HA - go to the bottom, generate a new token, paste into the server access token entry.

As an Addon this access token is not required, but it most certainly is otherwise!
You probably also need to ensure that ‘enable global context store’ is ticked too.

And open up the Conext Data in the three lines in the upper right corner and then click the refresh icon next to Global to see if there is any data in there.

The HA global context is no longer enabled by default. You will need to enable it in the server config.

All thanks a lot!
Enabling global context store did the trick