Not able to start Advanced SSH & Web Terminal

The add-on keeps shutting down. I’ve had this problem for months now and I’m not able to fix this.

These are the logs:

s6-rc: info: service s6rc-oneshot-runner: starting
s6-rc: info: service s6rc-oneshot-runner successfully started
s6-rc: info: service base-addon-banner: starting
-----------------------------------------------------------
 Add-on: Advanced SSH & Web Terminal
 A supercharged SSH & Web Terminal access to your Home Assistant instance
-----------------------------------------------------------
 Add-on version: 15.0.1
 You are running the latest version of this add-on.
 System: Home Assistant OS 10.1  (aarch64 / odroid-n2)
 Home Assistant Core: 2023.5.4
 Home Assistant Supervisor: 2023.04.1
-----------------------------------------------------------
 Please, share the above information when looking for help
 or support in, e.g., GitHub, forums or the Discord chat.
-----------------------------------------------------------
s6-rc: info: service base-addon-banner successfully started
s6-rc: info: service fix-attrs: starting
s6-rc: info: service base-addon-log-level: starting
s6-rc: info: service fix-attrs successfully started
s6-rc: info: service base-addon-log-level successfully started
s6-rc: info: service legacy-cont-init: starting
s6-rc: info: service legacy-cont-init successfully started
s6-rc: info: service init-user: starting
s6-rc: info: service init-ssh: starting
s6-rc: info: service init-mysql: starting
s6-rc: info: service init-mosquitto: starting
s6-rc: info: service init-docker: starting
s6-rc: info: service init-docker successfully started
s6-rc: info: service init-mosquitto successfully started
s6-rc: info: service init-mysql successfully started
[02:43:49] NOTICE: Session sharing has been disabled!
s6-rc: info: service init-user successfully started
s6-rc: info: service ttyd: starting
s6-rc: info: service ttyd successfully started
[02:43:50] INFO: Starting the ttyd daemon...
[02:43:50] FATAL: 
[02:43:50] FATAL: Configuration of this add-on is incomplete.
[02:43:50] FATAL: 
[02:43:50] FATAL: Please be sure to set at least an SSH password
[02:43:50] FATAL: or at least one authorized key!
[02:43:50] FATAL: 
[02:43:50] FATAL: You can configure this using the "ssh.password"
[02:43:50] FATAL: or the "ssh.authorized_keys" option in the
[02:43:50] FATAL: add-on configuration.
[02:43:50] FATAL: 
s6-rc: warning: unable to start service init-ssh: command exited 1
/run/s6/basedir/scripts/rc.init: warning: s6-rc failed to properly bring all the services up! Check your logs (in /run/uncaught-logs/current if you have in-container logging) for more information.
/run/s6/basedir/scripts/rc.init: fatal: stopping the container.
s6-rc: info: service init-mysql: stopping
s6-rc: info: service init-mosquitto: stopping
s6-rc: info: service init-docker: stopping
s6-rc: info: service ttyd: stopping
s6-rc: info: service init-mysql successfully stopped
s6-rc: info: service init-mosquitto successfully stopped
s6-rc: info: service init-docker successfully stopped
[02:43:50] INFO: Service ttyd exited with code 256 (by signal 15)
s6-rc: info: service ttyd successfully stopped
s6-rc: info: service init-user: stopping
s6-rc: info: service init-user successfully stopped
s6-rc: info: service legacy-cont-init: stopping
s6-rc: info: service legacy-cont-init successfully stopped
s6-rc: info: service fix-attrs: stopping
s6-rc: info: service base-addon-log-level: stopping
s6-rc: info: service fix-attrs successfully stopped
s6-rc: info: service base-addon-log-level successfully stopped
s6-rc: info: service base-addon-banner: stopping
s6-rc: info: service base-addon-banner successfully stopped
s6-rc: info: service s6rc-oneshot-runner: stopping
s6-rc: info: service s6rc-oneshot-runner successfully stopped
1 Like

You need to set a password or add a public key.

Did you set a password or at least one authorized key?

ok, now I’ve noticed the save button on the bottom is not a general save button. it now works… I feel so stupid for bothering you guys with this.

I thought it had something to do with this, because I had already tried to put in a password:

s6-rc: warning: unable to start service init-ssh: command exited 1
/run/s6/basedir/scripts/rc.init: warning: s6-rc failed to properly bring all the services up! Check your logs (in /run/uncaught-logs/current if you have in-container logging) for more information.
/run/s6/basedir/scripts/rc.init: fatal: stopping the container.

Nevertheless, your answer still solved my problem. Thank you guys for that!

1 Like

Just for future reference and for everyone who is struggling with this when the provided solution, that is setup of a password/public key for the SSH connection, is not enough.
I’ve had experienced the SSH addon that refused to connect and kept stopping itself continously, even though my user/password were set correctly.
The trouble in my case arised when using the configuration Debian + supervised HA (https://github.com/home-assistant/supervised-installer). I didn’t find any specific documentation but finally I managed to solve the issue after reading the debuggin guide available here: https://developers.home-assistant.io/docs/operating-system/debugging/.
The solution was as simple as to use the 22222 port instead the default one (22), that means the port to be used to connect in case of an instance running on Home Assistant OS.

4 Likes

Everyone?

No one in this seven month old solved topic had that problem.

Newbie here. I can’t get this add-on to stay on. I see the suggested fix is “You need to set a password or add a public key.” but where?

1 Like

Just found it in the configuration tab. A better error message wouldn’t have come amiss!

7 Likes

Thanks, it helped on HA Supervised

1 Like

Maybe people were just blaming themselves about doing something wrong, like i did, before i accidentally got to this topic

If anyone is having issues getting this working, specifically with Windows 11, I made a YouTube video walking through the setup in under 3 minutes. Give it a try and let me know if it works for you.

How to Install Advanced SSH & Web Terminal in Home Assistant

Fixed it for me. Stupid that is hidden

Changing the port to 22222 + adding the password into the text in the Addon’s configuration tab worked for me on HAOS. Cheers

Settings → Add-ons → SSH & Terminal → At the top of page go to Configuration