Not all the Tasmota switches are showing up

I have four Sonoff BasicR2 programmed with Tasmota. I have configured them all the same

All of the devices are being discovered and I can control the relay. The problem is that only two of the switches (binary input) are showing up in the overview.

How do I get all the switches (binary input) to show up?

I figured it out … setoption114 1, switchmode1 15, switchmode2 15

Also, all of the devices show the name of the binary sensors as Switch1 & Switch2. These can be changed by tapping on the switch as it is shown in the Overview, then clicking on the gear icon, typing in the name you want, then update

This is what I was going to write, maybe it will help someone else.

The Sonoff/Tasmota devices are configured as shown

In addition I have dissociated the switches from the relay with the console commands:
setoption15 1 setoption114 1
switchmode1 15
switchmode2 15

MQTT explorer shows that the switch information from each switch is being received.

I tried setting the switches to numbers other than 1 & 2 (Note that the switches of tasmota_59CF3F are 7 & 8)

The procedure I use when I make a change to a Tasmota device is as follows:

  1. make change in Sonoff/Tasmota device
  2. turn off (disconnect power) Sonoff/Tasmota Device
  3. delete the device in Home Assistant
    3a) Settings
    3b) Devices and Services
    3c) In the Tasmota card, click on 4 [Devices]
    3d) double click the device to be changed
    3e) click on the 3 vertical dots to the right of [VIEW DEVICE]
    3f) click on [Delete device]
    3g) yes I am sure, click on [OK]
  4. delete the Tasmota topics, “tele”, “cmnd”, “stat”, “tasmota”, on the MQTT broker:
    4a) click on topic
    4b) click on the trashcan in the upper part of the right pane
    4c) clicn on [YES]
  5. power on the Sonoff/Tasmota devices