Not having enough disk space available (on 64Gb sd card!)

Hi everyone,

I’m a bit desperate as I’ve tried to install hassio following the “standard” procedure on a brand new Raspberry Pi 4 a few times now for 3 days and always get the same error saying there’s no more space (on my 64Gb sd card). Note that I was able to make it work a few days ago with a 16Gb card, but the card was “burnt” by the raspberry…
I flashed several times the card with SD card formatter, took the latest 64 bit version from the website that I loaded onto the sd through Etcher (and also tried Win32DiskManager). I also tried with the 32 bit version, exact same happens.

  1. I start the ethernet-connected raspberry : green light show something is happening, BUT it doesn’t appear on my local network (even after more then 30 minutes).
  2. I unplugg / replug, and after a few minutes, the raspberry appear on the local network, and when I check on my browser, I arrive on the “preparing home assistant” page BUT… I see the error saying that’s it a 404 and there’s no space available:
Updateing image homeassistant/raspberrypi4-homeassistant:landingpage to homeassistant/raspberrypi4-homeassistant:0.116.4
Downloading docker image homeassistant/raspberrypi4-homeassistant with tag 0.116.4.
Can't install homeassistant/raspberrypi4-homeassistant:0.116.4 -> 404 Client Error: Not Found ("no such image: homeassistant/raspberrypi4-homeassistant:0.116.4: No such image: homeassistant/raspberrypi4-homeassistant:0.116.4").
This error is often caused by not having enough disk space available. Available space in /data is: 0.2 GiB

Here the full log.

Any ideas here ?

Thanks in advance !

I cant view your full log because I’m behind a corporate firewall that blocks pastebin, but you should look for a similar error to the one posted here only days ago:

Hi Tom,
Thanks for your feedback, I’ll try the beta.
And unfortunately I haven’t got trace of the next error he has : “under-voltage” (it would be surprising as I have an official charger), nor the ext4 problem.

So… Problem solved with a new 32Gb card. Strange as the 64Gb card works like a charm!

1 Like

same problem for me with a 64GB Sandisk Extreme A2 V30 sdcard…

Is there a bug in the 0.116.4 ???

EDIT : i try another 64GB Sandisk Extreme A2 V30 card and it works.

The first one works without any issue if i use it for files or another OS in another Raspberry…

There’s a lot of fake SD cards circulating these days. I’d be very wary of large capacity cards. If you’ve already used to format your card and are still having issues with it, it’s either fake or dead.

the 2 card comes from the same seller, buy both together, …amazon…dont think one is fake and other not,

i have already used both for HASSOS without issue.

i have made a snapshot and HA reboot in safe mode…there is something wrong with the 0.116.x update…search for that…dont want to begin from scratch…to much sensors, about 120…too much work…lol

No guarantee that both cards are the same, even via Amazon. Still if you think you have it sorted that’s the main thing.

Maybe there were 2 partitions made in the initial installation process?
Check the sd card in your pc with the disk manager.