Not installing in a virtual environment just bite me

Just tried upgrading from 0.73.2 to 0.74.0
and got the following

Cannot uninstall 'PyYAML'. It is a distutils installed project and thus we cannot accurately determine which files belong to it which would lead to only a partial uninstall.

Google shows… well i should have install in a virtual environment is the short of it.

i know what i’m doing at the weekend.

Ever thought of moving to docker?

I’m running my home stuff on ProxMox, DC, MAIL torrent etc. with only 50% RAM used and loads of hard drive space i tend to install virtual machines or containers, as that allows me to move them quickly using ProxMox.

I should really, but i like having a real system under my apps, makes me feel warm and comfy

Lol I get what you say. I was the same. Though since I moved to docker I have not had to do any troubleshooting after updates. Would never go back now

I’m starting to think that there is really nothing stopping me.

I just need to ssh from it, to send irsend commands.
and run python scripts.

I’ll look further into it or i’ll be stuck on 0.73.2 for a while

sudo rm -rf /usr/lib/python3/dist-packages/PyYAML-*

I dont run venv neither and ran this did rebot and everything is fine That I have tested

1 Like

@Vasiley thanks - this worked perfectly for me - kudos

I feel compelled to add a word of warning about this, for any noobs that come along copying things verbatim.

Removing package files manually is fine, providing there is nothing else on your system depending on it. If there is, you won’t find out until that doesn’t work.

It generally isn’t a good idea to remove things that were installed by a package manager (in this case pip) outside of the package manager. In fact, every time you use sudo rm should ring alarm bells, and bring on nervous twitches.:sweat:

The best way to install anything but the simplest python program is in a virtual environment. The worst that can happen then is that you have to delete that virtual environment and create a new one, which will not affect the rest of your system.

Thats fine. You have to half crazy like i am not to run a venv to begin with. It really dont matter i back up and can rebuild in no time.

Completely agree (he says copy and pasting the command as he’s unable to figure out how to do it himself) :joy:

It allowed me to upgrade, but i seem to have lost my side panels…
All say “error while loading this panel”
Roll back time for me.

It works fine after a second reboot ?!?!?

very strange…