Not receving Home Assistant notifications when remote, that is not connected to home network

I am currently running Home Assistant 2024.6.2 using the HassOS image running on a stand-alone x86-64 based machine.

I have created an automation in which one of the actions is to send an actionable notification to my Android based (Samsung Galaxy S22) phone. The notifications are seen and the action buttons respond as expected as long as I am connected to my home network.

Once I leave the home network, however, I no longer receive any notifications. I’ve checked my Companion App server settings. Originally the ‘Persistent connection’ was set to: ‘Never’, which indicates notifications will be delivered via Google. I switched this to ‘Always’ (Local Push), but was still not receiving any notifications when away from the home network.

I have Tailscale integration installed and while I successfully access my Home Assistant server when Tailscale is connected I never receive notifications even when I’m sitting back at home until I disconnect Tailscale.

There are no new messages within the system logs as a result of any of my testing.

My current Companion App ‘Connection information’ settings are: ‘Home Assistant URL’: http://homeassistant:8123/
I do not have any ‘Home network WiFi SSId’ configured and ‘Internal connection URL’ is grayed out.

I cleared the Home Assistant app cache & data, uninstalled and reinstalled it but I still am unable to receive notifications remotely.

For my remote notification testing I have the following setup within Developer Tools > Services:

service: notify.mobile_app_sm_s901u1
  message: Testing remote notification
  title: Remote Test Notification
    priority: high

I enable/disable WiFi on my phone to connect/disconnect from my home network, simulating home / away. When WiFis connected, notifications are received; when disconnected notifications are never seen until I reconnect to the WiFi.

I should also point out that I am no where near the maximum of 500 push notifications per day per device.

Am I mistaken in thinking that Home Assistant notifications can be received remotely? If Home Assistant does support remote notifications, I would appreciate any debugging advice to resolve this issue.

I’m aware there are other messaging integrations such as Telegram and Slack but my understanding of these is they do not support actionable notifications, so they don’t meet my requirements.

It’s definitely possible to receive notifications remote via a Tailscale connection. That’s what I have configured.

I’m not sure why you can access remotely, but not receive notifications remotely.

For me (and this took a bit of initial configuration and troubleshooting) I can connect locally with or without tailscale, and I can connect remotely with Tailscale. Pretty much everything works well.

For what it’s worth the http://homeassistant:8123 never worked for me (something to do with my network configuration I’m sure), so I used an IP address initially. However now it’s all set to a local domain name via reverse proxy.

I would suggest trying an IP address in the app just to see if it makes any difference. Also mine is set to “never” for persistent connection, and again it works just fine.

I too can connect locally with or without Tailscale, and I can connect remotely with Tailscale, but only if I set the ‘Home Assistant URL’ to http://homeassistant:8123/. If I use my local IP, I can only connect locally. If I use the Tailscale homeassistant IP I can only connect with Tailscale connected. If I use the Tailscale samsung-sm-s901u1 IP I can’t connect with or without Tailsscale.

With any of the above settings I never receive notifications when not connected to my home network.

I have set my ‘Persistent connection’ setting back to its original setting of ‘Never’.

I’ll do more online searching for documentation on setting all this up, but from what I’ve read to date it seems this should just work out of the box.

This made stuff click, although I’m still unclear about notifications it would be nice to get it working consistently with or without tailscale.

What if you input your home SSID and then you should be able to input an IP or hostname that reliably works at home. It’ll use internal when WiFi is connected. Then use put your Tailscale IP for external.

In my configuration I have a local DNS server that my phone uses when I’m connected via Tailscale. This means I can use the same hostname internal or external.

Well, after spending several hours yesterday, reviewing numerous Home Assistant and Samsung forums and verifying Samsung Galaxy S22 settings. I finally decided this morning to ‘bite-the-bullet’ and perform a reset of all my phone’s app preferences. On Samsung Galaxy S22 this can be found at: Settings > Apps > Tap the three dots in the top right > Reset app preferences > Reset. This was actually suggested by my cellular service provider when I contacted them to verify my APN settings.

Once done, I had to go in and reset Notification settings on those apps I was particularly interested in, eg. Home Assistant. Once I completed this I tested Home Assistant Notifications and they actually came through with Home WiFi only and with Cellular Network only.

Thanks to everyone here who responded. This solves the no notification on cellular network issue. I hope the information here will help anyone else experiencing a similar issue.