Nothing works correctly after the last update // zigbee conbee II //

hi everyone,

i am new here and i am not sure if there is a more specific forum here for my questions, but here we go:

i use home assistant with conbee II (zigbee) and i was very happy with it in the past. without expert knowledge i was able to setup homeassistant on a raspberry 4 and conbee II for zigbee. so i startet with some lightbulbs, motion detection and power outlets in my house and my garden.

everything worked fine for 3 months.

since one of the last updates - everything goes crazy and a lot of senseless things are happening:

  1. i have to register all my devices manually - that has never been the case in the past
    i have to start to connect the router, every repeater, and last but not least even the conbee II before zigbee works and anything starts to happen.

some of my devices have to be paired by hand after every restart of raspberry pi 4. it has never been this way before. i had to restart raspberry from time to time or even when the electricity went off there was no problem at all. raspberry just restartet, homeassistant restarted and worked just fine. . . in the past.

  1. everything has a heavy delay or is not working at all
    devices that worked relieable in the past are now shutting off all the time. nothing works as it was. every morning i have to restart the raspberry pi, because there is no answer from home assistant. sometimes the signal seems to be very delayed. like 10 seconds or more … and still i have to reconnect everything by hand after restart

  2. backup the settings for what?
    i never needed to return to any backup. stil i set the hook at “create backup” before i updated the home assistant. but there is no chance to get the old version back, is it?

i am no expert. i was so happy that everything worked more or less intuitivly in the past. i wonder what just happened. and my problem is serious: its becoming winter and dark really early, but no motion detecion or light is working anymore.

even worse: hass is controling my fishpump. which is not relieable at the moment. i am afraid some of the fish will die. same with my plants, since the automatisation for bringing water to the plants is not working relieable anymore. the pump deep in the ground is not working anymore - even if hass is pretending so (device seems activated - but its not).

the easiest way would be, to get back to a backup-version… so that would be my first question how to do that.

i am very thankful for any help. and sorry up in front for beeing so nooby at this field.



How are you running Zigbee? Z2M, ZHA, Deconz? What are your logs saying?

i used the integration deconz to start with the conbee II.
the logs look normal - as far as i can see. i don´t know what to look for in the logs exactly.

Check if you for some reason have enabled ZHA too. I would either way recommend you using ZHA or Z2M - if you anyway need to pair devices every reboot it should be worth the work to move over to one of those. Personally I use Z2M.

1 Like

pls excuse my stupid question … are ZHA and Z2M integrations, too? i don´t know what that is …

Not a stupid question :slight_smile: They are addons, not sure about ZHA since I don’t use it but Z2M you can also run externally to HA. Getting started | Zigbee2MQTT

1 Like

thank you… a lot of reading. this will take a while. . .
thank you very much. but i ll try to restore from an old backup first.
i stil wonder how (the hack) the whole system can be destroyed by only one update. it sucks.


i found a way to restore the backup. 3 versions before there was no problem. it looks like i have to pair most of the devices manually again now, but at least the working onces have no delay at this point.

hopefully some developer recognizes that the last updates causes a lot of hard mistakes and delays and fixes this. there is no reason to update at this point - it will destroy everything.

thank you for your answer fleskefjes.

No recent update should break your zigbee network, I’m quite sure there is something wrong but one would need more details about your setup to say for certain.

1 Like

i have no idea how to explain it better to you.
but at least i found out that ZHA is running… . i could read it when i had to activate the conbee II manually once again. i have to do this since a couple of versions ago. i made all the updates hass core offered me. but it makes no sense for me at this point to go that far back in time (before i did not have to restart the conbee II manually).

fleskefjes - i am very thankful for your words and beeing on my case. if you let me know how to get you more information about my case… i will do.

best, andré

If you run ZHA you should not be using Deconz. Uninstall Deconz / remove the integration and stick to ZHA. Remember Deconz is the software, Conbee 2 is the hardware. You need the hardware.

1 Like

thank you - i will try that right now.

To clarify: you have a choice to use either Deconz or ZHA or zigbee2mqtt with the conbee ii stick. But you can use only one to connect to the conbee ii stick. Don’t delete Deconz or ZHA until you are sure which one you actually use. Each possible integration has pros and cons, so switching should be an explicit, well thought choice. And it requires repairing if you switch.

Secondly, I’ve read another thread with similar problems, but regrettably as yet I have not found it. It involved deconz.

1 Like

thank you edwin! it helped a lot to delete the deconz app since i only installed it in the past for some testing. actually to find out about an aquara-button… . which is still not working. but after i deleted deconz now, and only zha is running, the configuration is back after restart. no need to reconfigure the conbee II all the time. it feels like i am on the right way. but it looks like i have to pair some devices again.

thank you guys for your help. that saved my day.

i really appreciate that! thank you so much!


1 Like

Glad you got it working.

1 Like

yes man - you (!) made my day with your answers!
i just finished (re)pairing what was missing, and finally everything seems to be back to normal.

i just love you!
tank you!


1 Like

My ZHA integration takes a real dump every time I do a OS or Core update. It’s brutal. Conbee II with ZHA