Notification not received on iPhone

I have mobile_app and ios in my configuration and I have the mobile app working on my iPhone. The phone shows up in HA. When I go to Developer Tools I have a notify.mobile_app_my_phone. When I enter a test, i.e. message: “hello world”, I do not get the notification on my phone. I’ve tried with and without quotes.
I used the script editor to create a basic test script. When I trigger the script I get a message in the browser and in the logbook that the script started - but again, no notification on the phone.
I am stuck - what else should I be looking at to solve this issue?

‘1578869353767’:
alias: Message to Bob’s Phone
sequence:

  • data:
    message: My message
    title: My title
    service: notify.mobile_app_bob_berryhills_iphone

I’m probably not the one who should offer advice, but when I had a similar problem I deleted my phone (device_tracker.name) off of HA. I restarted HA and when that was done I went into app config on my phone and reset it. From there I logged in again onto my phone. I tested from there and it worked. YMMV

https://companion.home-assistant.io/en/troubleshooting/setup

Thanks - I’ve seen that doc and followed the steps, but it never hurts to do them again.

  1. So, I have the notify service.
  2. Pretty sure the payload is good.
  3. Reset your token id - did this again and force quit the app and restart Home Assistant.

I still did not get a notification but when I went back to the app and checked the notifications I noticed 1 attempt and 1 delivered. I sent another notification from HA and the attempts incremented to 2 and the delivered incremented to 2.

So now I am probably gonna feel kinda dumb - but I don’t see the notifications. No notification alert and nothing in the notification center.

On the phone’s settings -> notification section I do not see the Home Assistant app like I see all of the other apps - should it be there?

Hi bberr,
Did you find a solution for your issue? I have the same issue.
I also see:
‘I still did not get a notification but when I went back to the app and checked the notifications I noticed 1 attempt and 1 delivered. I sent another notification from HA and the attempts incremented to 2 and the delivered incremented to 2.’
But no messages on my iphone… frustrating…

Does my phone block it somehwere?
Also I have this what you described:
‘On the phone’s settings -> notification section I do not see the Home Assistant app like I see all of the other apps - should it be there?’

I just found my solution… it was the phone, or the app, or something like that.
What I did:
I removed the app from the phone and re-installed it.
During initialization it asks to allow push notifications. During the first time installation I didn’t allow this. No idea how to undo that, but at least the re-install->allowing it worked.
I’m so happy now, sending notifications to myself :slight_smile: :rofl:

The initial Allow Buttons on install are CONFUSING.

At default, they show “Allow” - which seems to indicate current state is already set to Allow. However, you have to Click on it, to turn “Allow” into “Allowed”. That is a UI convention followed by … no one.

Given confusion noted above, app’s UI designer should tweak to less-confusing input for these choices - ESPECIALLY since they cannot be changed later (without deleting and re-installing app).

I had the same problem. Deleting and reinstalling the app worked for me. I think I also may have accidentally disabled “discovery” in the config.