Notifications Alert

good morning guys, ever since i upgraded my HA instance to 0.88, i kept getting this notification alert every time i restarted HA.
Anybody have an idea on how i can go about fixing that.

Somewhere in your configuration files you have configured several components with an option called flash. It is not a valid option.

Search through your configuration files and delete the lines containing the flash option.

You can use a Linux command to recursively search through all configuration files for the word flash. Ensure you are located in the configuration directory when executing this command:

grep -rni "flash"

most likely one of your lights has this as an option
I used to have flash: true in my config which generated the same errors you reported
Take that line out

ok guys and thank you for your reply; i will take another look.

I have the same message every time I restart my after 0.88. Did a search in the IDE add-on.

Searching for flash in/config (Found 44 matches in 19 files)

7: Please remove [flash].

5: board_flash_mode: dout

5: board_flash_mode: dout

5: board_flash_mode: dout

12: board_build.flash_mode = dout
39: -Wl,-Teagle.flash.1m0.ld

12: board_build.flash_mode = dout
39: -Wl,-Teagle.flash.1m0.ld

24: -Wl,-Teagle.flash.4m.ld

12: board_build.flash_mode = dout
36: -Wl,-Teagle.flash.4m.ld

12: board_build.flash_mode = dout
37: -Wl,-Teagle.flash.4m.ld

12: board_build.flash_mode = dout
35: -Wl,-Teagle.flash.4m.ld

12: board_build.flash_mode = dout
35: -Wl,-Teagle.flash.4m.ld

12: board_build.flash_mode = dout

12: board_build.flash_mode = dout
40: -Wl,-Teagle.flash.1m0.ld

12: board_build.flash_mode = dout
41: -Wl,-Teagle.flash.1m0.ld

12: board_build.flash_mode = dout
41: -Wl,-Teagle.flash.1m0.ld

12: board_build.flash_mode = dout
41: -Wl,-Teagle.flash.1m0.ld

12: board_build.flash_mode = dout
41: -Wl,-Teagle.flash.1m0.ld

12: board_build.flash_mode = dout
35: -Wl,-Teagle.flash.4m.ld

Found 43 matches in 18 files

Nothing here tells me that there is anything wrong in my configuration. Any ideas?

can you post the content of /config/esphome/ATC1.yaml (remove any credentials if you have any)
the issue won’t be with the *.ini files

Also how did you add ESPHome to your Did you use an add on ( or did you do it manually?

Sure :slight_smile:
ESPHome is installed with the official add-on, current official release as well.

  name: atc1
  platform: ESP8266
  board: esp01_1m
  board_flash_mode: dout

  ssid: 'xxxxxxxxx'
  password: 'yyyyyyyyy'


# Enable logging


  port: 80

  - platform: status
    name: "ATC1 status"
  - platform: gpio
      number: GPIO0
      mode: INPUT_PULLUP
      inverted: True
    name: "ATC1 button"
      - switch.toggle: pushbutton

  - platform: template
    name: "ATC1"
    optimistic: true
    id: pushbutton
    - switch.turn_on: relay
    - light.turn_on: led
    - switch.turn_off: relay
    - light.turn_off: led
  - platform: gpio
    id: relay
    pin: GPIO12

  - platform: esp8266_pwm
    id: blue_led
      number: GPIO13
      inverted: True

  - platform: monochromatic
    name: "ATC1 Blue LED"
    output: blue_led
    id: led

I’ve this multi-sensor configured with esphome in HA, somehow esphome set the “icon” option to " icon: mdi:flash" in the light brightness section.

    "data": {
        "binary_sensor": [
                "device_class": "motion",
                "is_status_binary_sensor": false,
                "key": 3708693722,
                "name": "GuestBedroom Motion",
                "object_id": "guestbedroom_motion",
                "unique_id": "guestbedsensorsbinary_sensorguestbedroom_motion"
        "cover": [],
        "device_info": {
            "compilation_time": "Mar  2 2019, 22:03:08",
            "esphome_core_version": "1.11.2",
            "has_deep_sleep": false,
            "mac_address": "2C:3A:E8:06:49:0D",
            "model": "PLATFORMIO_D1_MINI",
            "name": "guestbedsensors",
            "uses_password": true
        "fan": [],
        "light": [
                "effects": [],
                "key": 341103076,
                "max_mireds": 0.0,
                "min_mireds": 0.0,
                "name": "GuestBedSensors Light",
                "object_id": "guestbedsensors_light",
                "supports_brightness": true,
                "supports_color_temperature": false,
                "supports_rgb": true,
                "supports_white_value": false,
                "unique_id": "guestbedsensorslightguestbedsensors_light"
        "sensor": [
                "accuracy_decimals": 2,
                "icon": "mdi:flash",
                "key": 1322289085,
                "name": "GuestBedBrightness",
                "object_id": "guestbedbrightness",
                "unique_id": "2c3ae806490d-adc",
                "unit_of_measurement": "lux"
                "accuracy_decimals": 0,
                "icon": "mdi:wifi",
                "key": 2919709466,
                "name": "GuestBedWiFi Signal",
                "object_id": "guestbedwifi_signal",
                "unique_id": "2c3ae806490d-wifisignal",
                "unit_of_measurement": "dB"
                "accuracy_decimals": 0,
                "icon": "mdi:timer",
                "key": 2363892524,
                "name": "GuestBedSensors Uptime",
                "object_id": "guestbedsensors_uptime",
                "unique_id": "2c3ae806490d-uptime",
                "unit_of_measurement": "s"
                "accuracy_decimals": 1,
                "icon": "",
                "key": 1102178522,
                "name": "GuestBedroom Temperature",
                "object_id": "guestbedroom_temperature",
                "unique_id": "guestbedsensorssensorguestbedroom_temperature",
                "unit_of_measurement": "\u00b0C"
                "accuracy_decimals": 0,
                "icon": "mdi:water-percent",
                "key": 1424769827,
                "name": "GuestBedroom Humidity",
                "object_id": "guestbedroom_humidity",
                "unique_id": "guestbedsensorssensorguestbedroom_humidity",
                "unit_of_measurement": "%"
        "switch": [
                "icon": "mdi:restart",
                "key": 3314338689,
                "name": "GuestbedSensors Restart",
                "object_id": "guestbedsensors_restart",
                "optimistic": false,
                "unique_id": "guestbedsensorsswitchguestbedsensors_restart"
        "text_sensor": [
                "icon": "mdi:new-box",
                "key": 1910351955,
                "name": "GuestBedEsphomelib Version",
                "object_id": "guestbedesphomelib_version",
                "unique_id": "2c3ae806490d-version"
    "key": "esphome.584f1298293a4c6db2a129705e97a3ff",
    "version": 1

Here’s my config.

I had flash: true on some MQTT lights, but removed it, and still get the error message, just without a line reference to my lights config.

I also haven’t been able to figure out what is causing it

I also use esphome so wonder if it is related to that

possibly, I don’t use ESPHome (yet)…