Notifications not working after HA reinstall

I have 2 HA servers, both running on docker compose. I send notifications from both to my iPhone. One server had a drive failure and had to be reinstalled and since then, I can’t get that server to send notifications to my iPhone. It shows that it sent on the front end but never does and I’m getting the following message in the logs: Error sending notification to Home Assistant Mobile Apps ClientConnectorError. I did have a backup of the old files before it crashed and am using them for the config, automations, etc.

I have disabled the firewall with no change. I have added another device and tried to send notifications to it with no change.

Any advice on what to try next?

Verify device name matches service

On phone

Settings >> general >> about >> name

You should be sending to service notify.mobile_app_name

When I select the notification device, it shows the full and name of the iPhone or iPad and the action shows successfully sent, however the log does not show that name. I didn’t paste the entire message before but here is what I get regardless of what device I select to send it to.

Error sending notification to Home Assistant Mobile Apps ClientConnectorError(ConnectionKey(host=‘’, port=443, is_ssl=True, ssl=True, proxy=None, proxy_auth=None, proxy_headers_hash=4415596840847704901), gaierror(-3, ‘Try again’))

I also just noticed something else. Both the iPad and iPhone show in devices, however, when I select automatons that use those devices, it shows none.

Here is the yaml from the automation
service: notify.mobile_app_ipad_3 data: message: test

The name of your iPad in iOS settings is “iPad 3”?

Look at the notify services available in HA >> developer tools >> services

What is there and does it match iPhone/ipad name? They will each have a notify service registered.

Is this being called by the automation?

It is possible a new service was registered when you log in with device and it is not matching automation. Make sure your calling the correct service and that it is a valid service.

Yes, Ipad 3 is the correct name.

services shows Notifications: Send a notification via mobile_app_ipad_3. The iPhone is also listed correctly. I’ve selected both with an automation and the trace shows that it was fully completed and shows that it was sent to both the phone and ipad but it never receives on either and the log file increments with the same error message again.

Oddly, I had as DNS and also added and it now works! Go figure???

In HA app or in IOS?