Notifications not working in 2.0 Beta

Did you try my steps? Make sure to delete it first and restart home assistant before you attempt to connect it again.

  1. Delete app from phone
  2. Remove integration from HA
  3. Restart HA
  4. Reinstall app on phone
  5. Open app and start onboarding
  6. At the last screen you MUST press the allow notifications button.
  7. When phone is connected to HA, refresh the page and restart HA but leave your phone open (make sure it doesn’t lock when it is restarting) move your finger around the screen until it is restarted
  8. Refresh your phone screen
  9. Go to dev-tools > services and check if you have the following service: notify.mobile_app_yourname
  10. If it is there it should work! Happy notifying

This method has worked for me on several iphones for almost a year for a 100% out of all attempts. If you still cant get it to work I’d suggest reading the official docs on how to clean it.

2 Likes

Wow, thanks for replying so quickly. It was my own stupidity, lack of attention to detail, and home assistant novice that killed me. On the start up screen of the HA companion app I read ‘Allow’ as ‘this is allowed already, no need to toggle.’

Funny enough toggling ‘Allow’ changes it to ‘Allowed’ and it’s working now.

1 Like

Thanks this worked for me. I think what really helped me was removing the integration, resting the push ID in the app and restarting HA