Notifications not working in 2.0 Beta

I’m probably doing something wrong but this one has me stumped.

I’m using the mobile app build 62, and in Home Assistant I have both mobile_app: and ios: in my configuration. The mobile device notification targets are showing up, and I’m able to call notify.mobile_app_phonename with no errors.

When I make a notification call, the notification counter in the mobile app’s settings (App Configuration --> Notifications --> Rate Limits) does increment each time; both “Attempts” and “Delivered” increase by one for every (invisible) notification. I have push notifications turned on in TestFlight.

And yet . . . no notifications are coming through to my phone, at all. Any ideas? Pushover has been great for me, but I’d really like to move to native notifications.

It’s working following a delete and reinstall of the app. I think it was an iOS glitch of some kind - the app was previously not showing up in Settings under Notifications at all, but it is now, and the notifications are coming through.

I have the same problem
already deleted and reinstalled the app but notification still not are visible

Step 1: delete app from phone
Step 2: delete integration in HA via the integrations menu (Do NOT forget this!)
Step 3: restart HA
Step 4: reinstall beta app on phone
Step 5: start onboarding process
Step 6: when onboarding process complete pull down to refresh
Step 7: restart HA but leave the app open (and make sure your phone doesn’t lock or blackout the screen)
Step 8: Happy notifying

Notifications can be sent via the notify.mobile_app_your_iphone service.

You will NOT be able to use the iOS services any longer as they are not used in 2.0. ios is deprecated, mobile_app is the current method. Actionable notifications set in ios will still work though. You might need to create a fake action in the app for them to work properly.

Good luck.


Reinstalled and removed the integration a few times and now it’s working again
Thanks for your idea, did it in that way

Thanks for that, got mine sorted now, just have to tell the wife not to upgrade her app until next week when I can do her notifications. Now to see if I can get a snapshot of who is at the front door. I have the camera snap shot URL and it is the HIK Vision analytics that drives the automation - TTS to Alexa and iPhone Notification.

Hi folks

I have the same issue but with the production v2 app.
I have followed the instruction on the mobile app wiki exactly. I have the location, pedometer and battery sensors all working. But I cannot get notify to work at all. I am using an iOS phone I have also simply tried sending a notify message from the developer tab section and still nothing. I am using the notify mobile app with my correctly identified iPhone.

I also get the increment in attempts and delivered with each message but no actual notification

I followed the above instruction as well but still nothing.

Is there another prerequisite that is not listed in the notify wiki ??

I am at a loss as all the examples are all so simple and straightforward

Thanks for any help


I suggest checking your notification permissions in iOS settings>Home Assistant. If all looks OK, try resetting your Push ID within the App from going to App Configuration>Notifications>Reset. Then restart HA and try again

Hi Tom

Thanks for the suggestion - I have every possible option enabled in the app under notification and privacy.

I did as you suggested again but no luck. But the message counts continue to increment.

My phone name is al’s iPhone but I notice in home assistant it is alsiphone not sure if that is an issue. Also I have not created a specific category?


Ok this makes two of us now. I have the exact same issue AIRos is having. Receiving increment in attempts and delivered but no notification. Also HA Companion does not show up in the iOS setting / notification section.

AlRos try uninstalling and reinstalling the companion app on your phone. When you configure it to connect to HA there are three options that come up with allow buttons. Click the allow button for notification. I did this and now I see it in my notifications section.

yep thats it.
if all is well now you should then see this:

Yep notifications are now working. Maybe it’s just me but this doesn’t seem very intuitive to me. I also find it interesting that location services are configured even if you don’t click the allow button in the beginning.


I can’t believe how much time I spent on this! Yes the three options during the app install appeared like the options were already “allowed”. It seemed like if I toggled them they would toggle to not allow.

Any way thank you to all that helped clarify this issue and such a simple oversight that drove me crazy !! Once I actually pressed on allow - the colour changes and now every thing works

Happy new year and holidays

Just tried this with the 2.0 beta app and sadly it didn’t work. Notify still broken and geocoded location still broken. I just get a new sensor (for example sensor.geocoded_location_13). So somewhere HA is keeping track of all the previous sensors and not nuking the integration/configs properly…

@daneboom You likely need to go through the full cleanup:

I’ve done all these steps countless times and still nothing. I’ve named my phone “Chris” under the mobile app integration but still after many attempts only notify.mobile_app_iphone shows up. This wouldn’t be a problem if I wasn’t trying to send different notifications to different iPhones.

The notify service cannot be renamed in HA. It will take the name from the ios device name set in ios settings.

I’ve named the device Chris iPhone in the integration but it still just shows up as notify. Mobile_app_iphone in the services tab.

I too am in the same boat. I’ve followed the instructions above several times with no luck. Also on an iPhone, receiving increment attempts, no app in the notifications setting within the iPhone–I’m at a loss. Will we have to wait until there’s an update to the app? It was all working fine last week which is the most frustrating thing about this.