Notifications stopped working

All my notifications just stopped working; I haven’t changed anything

here’s one example of an automation

- id: '1549397170480'
  alias: Started
  - event: start
    platform: homeassistant
  condition: []
  - data:
          badge: 1
      message: HA Started!
      title: Smart Home Alerts
    service: notify.ios_ipad

when I edit an automation and click “execute” to test it, nothing happens
I also tried changing the target device with no luck

I just found this error in the log

Try the suggestions in this issue:

I don’t see the solution there; however my problem was that the Home Assistant iOS integration now requires to use “notify.mobile_app_device_id” instead of “notify.ios_device_id”

A simple find and replace in the automation.yaml solved it

It’s hard to fault find when given false information like this:

You did change something. You updated the app.

It would be nice if updates didn’t break existing features

However, I’m still not clear what caused it. Is it the iPhone app (in which case it’s autoupdating), or the Home Assistant integration (how does this get updated?)
I’ve only ever updated whatever appears in “Supervisor/dashboard”, there’s normally 2 things to update and I have no idea what the difference between the 2 is…

It stopped working again for no reason; I’m using the correct service now and I haven’t updated anything
Notifications are working on my iPad, but not on my iPhone
I can see three instances of my phone in “integrations”, not sure why, but only one selectable in services…mobile

Notifications to the iPad still work and they work on both devices if I use the serivce “notify.notify”

1 Like

Just a thought…did you reach the max. notification limit? On Android there is a new limit at 300 notifications a day

Who sets the notification limit? I’m testing some automations and now i’m not getting notified. Is there a way around this?

As far as I know this is set from the App itself Push Notifications | Home Assistant Developer Docs (

I moved all my notifications to the Telegram integration. So far this has been working much better

Need help. The minute I updated HA to OS 9.0 my notifications stopped working and I get the following error every time my automation triggers a notify.moble_app_xxx event:


Here’s my code:

- id: cat_is_fed
  alias: "Cat is Fed"

    - platform: state
      entity_id: binary_sensor.wifi_feeder_feeding

    - service_template: > 
        {% if is_state('person.zach', 'home') %}
        {% elif is_state('person.eric', 'home') %}
        {% endif %}
        message: "Cat Feeder Activated!"

  mode: single

I have at least 20 notifications setup just like this and all was fine until I updated Home Assistant. My companion app integration looks fine, mobile_app phone names are correct, etc. What happened?

I read somewhere on the forum that if you’ve updated to the latest iOS (16?) then the companion app doesn’t have access to the phone’s name anymore, so you will get a generic name in HA and for all of that phone’s sensors. So, go to the developer tools or integrations page and find the sensors and devices. It might as simple as renaming the device on the integrations page, which should rename all the sensors too.


That was exactly my issue! I didn’t think it was because my husband updated to iOS 16 as well and his notifications never failed. Odd behavior, but much appreciated none the less! Thank you!

1 Like