Notify.notify not working on iOS

I have a service notify.notify to send a message and title to my smartphones. For android it works fine, but the iphone doesn’t show the notification (iphone 7).
Do I need additional configuration for iOS?

Heres my config:

# Timer for open windows (900 sec = 15 min)
    name: Time remaining (Window)
    duration: 900
# Switch for open window
  - platform: mqtt
    name: "Window open"
    state_topic: "zigbee2mqtt/bridge/config/open_window"
    command_topic: "zigbee2mqtt/bridge/config/open_window"
    payload_on: "true"
    payload_off: "false"

  # Automation to start timer when window is open
  - id: window_open
    alias: Window open
      platform: state
      entity_id: switch.window_open
      to: "on"
      service: timer.start
      entity_id: timer.window_open
  # Automation to stop timer when timer finished
  - id: close_window_nofitication
    alias: Notification for open window
      - platform: event
        event_type: timer.finished
          entity_id: timer.window_open
      - service: timer.cancel
          entity_id: timer.window_open
      - service: switch.turn_off
        entity_id: switch.window_open
      - service: notify.notify
          message: "Fenster schliessen"
          title: "Fenster schliessen"

for the past few versions now (can’t remember which one, but we’re talking 3-7) iOS notify has changed to use mobile app.

I’m not using notifiy.ios_iphonename. I want to send the notification to all registered smartphones, therefore I tried notify.notify. If I add it your way I have to update the service everytime I get a new phone.
The iPhone runs with iOS 13. So is this a problem related to home-assistant? Or do I have to configure something to make iPhones work?

Does notify.mobile_app_iphone_name_as_shown_under_ha work on a single phone?
Have you tried to import push notifications from server from the app settings on your phone?

I have tried it and it didn’t work. When I edit my automation in the HA ui I couldn’t even see notify.mobile_app_iphone but I see notify.mobile_app_samsung_phone. I saved it anyway and no response on the phone. After changing back to notify.notify the iPhone now gets the push notifications. Very strange but now it works as expected.
Thanks for your help!

Have you added mobile_app: to your config ?

No i didn’t the phones were auto discovered

if you want to fully use the capabilities of your mobile phones (and the HA app on it) you need this
Glad to hear it’s resolved

@lolouk44 As unexpected as it was working, it now doesn’t work after I had to reinstall the HA app on the iPhone.
The service is available in the ui and I can trigger a notification with this service. In the iOS HA app under app configuration -> notification settings I can see that the notify is received at the mobile app (at the bottom of this page). But the notification is not popping up. I think I gave all rights possible to the HA app.
Do you have an idea why the app recognizes the notify but don’t show it?

Make sure you tap on import push notifications from server in the app again after a reinstall.
You may also want to double check your iOS settings under notifications to ensure the app is allowed to send notifications…

I reinstalled the application again and found my mistake. When installing the application it is asking for permissions. And I thought allow means it is enabled. But you have to click on allow and agree then it says allowed.

Thanks for your hints!

1 Like