NSPanel - Can't get by "waiting for content"

Hi all,


  • Upon plugging in the NSPanel, the display is stuck at the main screen with the message “Waiting for content… This is taking longer than usual, please check your backend configuration”

I flashed with Tasmota and successfully got the LovelaceUI working as expected following these instructions:

I think I the problem started after I updated HACS

At this point I figured maybe I’ll try NSPanel Custom with HA Blueprint because that looks like possibly both a way out of this and maybe another good option

  • I followed HOW TO - Flash Sonoff NSPanel with ESPHome where I followed all instructions where at the end I called the service ESPHome: nspanel_upload_tft and that seemed successful but the panel display still is stuck in the “Waiting for content…” message I specified in the problem description

I figured the problem is that I probably need to get by the “Waiting for content…” message before I can move forward so I tried reinstalling Tasmota but that ended up resulting in the NSPanel just displaying a blank/black screen, so I flashed again w/ ESPHome and I’m back to my “Waiting for content…” message

In ESPHome it looks good (see below log and how I’m able to turn the relay on/off (and hear a “click” on the NSPanel when I do))

I was also thinking that maybe Factory restore for NSPanel might be an option but I don’t think so since I can’t get to the Tasmota UI to run the command for the tft file

Quick update on this, I did the following so that I’m now able to at least start, but unfortunately not successfully flash the nspanel-us.tft

  • Reverted back to Tasmota (see my original post)
  • In HA: File editor, go to config/www folder (if you don’t have one, create it), click Upload file and upload nspanel_blank.tft
  • From the Tasmota console, run the following (which produced a blank/grey (not black) screen): FlashNextion http://IP_ADDRESS_OF_MY_HOME_ASSISTANT:8123/local/nspanel_blank.tft
  • Then flashed NSPanel with ESPHome following HOW TO - Setup the SIMPLEST Smart Home Scene Controller

At this point I try to flash nspanel-us.tft in HA using Developer Tools->Services->ESPHome: nspanel2_upload_tft_url (which I also uploaded to my config\www folder) but consistently my ESPHome log shows “Ping response not received after 90.0 seconds…” occurred after about 20%, but it continued successfully until consistently (I tried several times) 30% (and 2424832)

Did you ever figure out what the problem was?
I’m having the same issue atm.

Hi @wolter, I tried literally everything under the sun to get it working and it just wasn’t happening so I ended up buying a new NSPanel and it worked effortlessly. I can only conclude that the old one, which I know I purchased when the NSPanel very first came out, is somehow different than the one I just bought.

I also had the same issue with the NSPanel that I bought mid 2023. I eventually got it working after hours and hours of trying.
It was stuck in the waiting for content screen, this is taking longer than usual. I spent a good 3 or 4 hours yesterday trying to fix it. I then woke up this morning and gave it one more shot and it started working.
I decided to strip my apps.yaml and the appdaemon.yaml down and it started working.
So this is what it looks like now. I haven’t modified or added anything else to it yet.
I really hope it helps because it’s so frustrating.

and this