NSPanel ESPHome Thermostat not working after doing some updates

I’ve had the NSPanel flashed with ESPhome and configured using the Blackymas template. It controls my Central Heating too with one of the relays. Been working fine for 6 months or so.
Just come back from a long holiday and found lots of HA Integration/add-on updates due so just rolled through them including one for ESPHome (to 2023.12.9) and I think the NSPanel.
Now all the configuration stuff on the Panel itself has gone and no Central heating.
I’ve still got the ESPHome config file and the populated automation templates and so tried reinstalling them and uploading the templates but still nothing is working.
Looking at the Log from the ESPHome Add-On this repeats every 1 minute.

[23:20:57][D][esp32.preferences:114]: Saving 1 preferences to flash...
[23:20:57][D][esp32.preferences:143]: Saving 1 preferences to flash: 1 cached, 0 written, 0 failed
[23:21:07][D][sensor:094]: 'ntc_source': Sending state 1.75800 V with 2 decimals of accuracy
[23:21:07][D][resistance:039]: 'resistance_sensor' - Resistance 12768.9Ω
[23:21:07][D][sensor:094]: 'resistance_sensor': Sending state 12768.87207 Ω with 1 decimals of accuracy
[23:21:07][D][ntc:026]: 'Temperature' - Temperature: 19.6°C
[23:21:07][D][sensor:094]: 'Temperature': Sending state 19.59893 °C with 1 decimals of accuracy
[23:21:07][D][climate:396]: 'Thermostat' - Sending state:
[23:21:07][D][climate:399]:   Mode: OFF
[23:21:07][D][climate:401]:   Action: OFF
[23:21:07][D][climate:419]:   Current Temperature: 19.60°C
[23:21:07][D][climate:425]:   Target Temperature: 18.00°C
[23:21:07][D][addon_climate_base.climate.thermostat_embedded.on_state:055]: Starting
[23:21:07][D][script:077]: Script 'refresh_notification' restarting (mode: restart)
[23:21:07][D][addon_climate_base.climate.thermostat_embedded.on_state:058]: Finished
[23:21:07][W][component:214]: Component adc.sensor took a long time for an operation (0.05 s).
[23:21:07][W][component:215]: Components should block for at most 20-30ms.
[23:21:08][D][sensor:094]: 'RSSI': Sending state -50.00000 dBm with 0 decimals of accuracy
[23:21:15][D][text_sensor:064]: 'Version ESPHome': Sending state '4.2.5'
[23:21:15][D][text_sensor.version_esphome:1773]: ESPHome version: 4.2.5
[23:21:15][D][script:077]: Script 'check_versions' restarting (mode: restart)
[23:21:30][I][script.watchdog:3209]: Wi-Fi:         Good (-50 dBm)
[23:21:30][I][script.watchdog:3228]: API:           Connected
[23:21:30][I][script.watchdog:3246]: Blueprint:
[23:21:30][W][script.watchdog:3251]:   Init steps:  0 (0.0%)
[23:21:30][W][script.watchdog:3252]:   State:       Pending
[23:21:30][I][script.watchdog:3253]: Requesting blueprint settings
[23:21:30][I][script.watchdog:3263]: ESPHome:
[23:21:30][I][script.watchdog:3264]:   Version:     4.2.5
[23:21:30][I][script.watchdog:3275]:   Heap:        118988 bytes (40%)
[23:21:30][I][script.watchdog:3277]:   Framework:   ESP-IDF
[23:21:30][I][script.watchdog:3280]: UART:
[23:21:30][I][script.watchdog:3281]:   Baud rate:   115200 bps
[23:21:30][I][script.watchdog:3282]:   Queue size:  8
[23:21:30][I][script.watchdog:3286]: Nextion:
[23:21:30][I][script.watchdog:3287]:   Queue size:  2
[23:21:30][I][script.watchdog:3289]:   Is setup:    True

I read in the Blackymas Github page about keeping ESPHome, TFT file and Blueprint versions in sync, so I tried updating the TFT file as per the instructions but nothing seemed to happen.
On the NSPanel Device page under Diagnostic it’s telling me:

Version Blueprint       Unknown [Pretty sure it's 4.1.4]
Version ESPHome         4.2.5
Version TFT             4.1.4

So I looked for the TFT file to load locally (as I did for the original install) but confused by the ‘Bump to 4.2.6’ thing!
Help please.