NSpanel failed Firmware Update


I have a Nspanel which I have flashed with ESP32, uploaded the blank TFT file and got lucky with using AppDaemon & MQTT to control it (used this HowTo: Prepare NsPanel - NsPanel Lovelace UI Docs). Now this worked for weeks like a charm, no problems, until yesterday… the Display was showing a message to update the Firmware (the options have be directly shown on the screen) . So I clicked OK and this is where desaster struck. The Update process was standing still at about 45% for nearly 9 hours, nothing happened. So I pulled the plug…after that, SYSTEM DATA INVALID was shown on the screen. Oh boy.

Ok, so using the services to upload the TFT file… did not work. Connection refused.

Now I reflashed the ESP (which worked), but for the screen it did not help.

After some research, I installed a blank TFT file, using Nextion Editor (which worked as well), so I ended up with a white screen now. Ha. Tried to execute the service, but same result, connection refused.
Logfile shows just this

023-08-25 07:28:22.617 WARNING (MainThread) [aioesphomeapi.connection] nspanel1 @ Connection error occurred: [Errno 104] Connection reset by peer

So I am out of ideas, what I could do next to get the panel to cooperate again.
Any ideas would be greatly appreciated