NSPanel: impossibile set temperature into thermostat page

I have an nspanel with tasmota.
I can’t set manually termperature into thermostat page of nspanel or set manual mode (it is always set on auto mode).
I tried by tasmota console to run follow commad, but not works…

NSPSend {"ATCEnable":0,"ATCMode":0,"ATCExpect0":27}
NSPSend {"ATCEnable":1,"ATCMode":0,"ATCExpect0":27}

Ideas???

Hello :slight_smile:

If you want set temperature via hassio or in tasmota use command cmnd/nspanel/nspsend {"ATCMode":0,"ATCExpect0": value for temperature} if you want use manual or automatic thermostat change ATCMode 0 is manual 1 is automatic. If you want turn off thermostat add command in line "ATCEnable":1 0 is off 1 is on

in nspanel.be you have to change:

class NSPanel : Driver
  # set thermostat options
  static atc = { 
    "id":     "thermostat",
    "outlet": "0",  # outlet to use for trigger
    "etype":  "hot", # hot or cold
    "mirror":  false, # if true Tasmota will resend triggers as commands to keep the state on screen

to:

class NSPanel : Driver
  # set thermostat options
  static atc = { 
    "id":     "thermostat",
    "outlet": "0",  # outlet to use for trigger
    "etype":  "hot", # hot or cold
    "mirror":  true, # if true Tasmota will resend triggers as commands to keep the state on screen

“mirror”: true,

then in configuration.yaml add:

under switch:

  - platform: mqtt
    name: "NSPanel relay 1"
    state_topic: "stat/NSPanel/POWER1"
    command_topic: "cmnd/NSPanel/POWER1"
    availability_topic: "tele/NSPanel/LWT"
    qos: 1
    payload_on: "ON"
    payload_off: "OFF"
    payload_available: "Online"
    payload_not_available: "Offline"
    retain: false

and under sensor:

  - platform: mqtt
    name: "NSPanel temp"
    state_topic: "tele/NSPanel/SENSOR"
    unit_of_measurement: "°C"
    value_template: "{{ value_json['ANALOG'].Temperature1 }}"

then to have the thermostat running in HA (but not on the panel):

climate:
  - platform: generic_thermostat
    name: Thermostat
    heater: switch.nspanel_relay
    target_sensor: sensor.nspanel_temp
    min_temp: 10
    max_temp: 30
    ac_mode: false
    cold_tolerance: 0.3
    hot_tolerance: 0.3
    min_cycle_duration:
      seconds: 5
    keep_alive:
      minutes: 1
    initial_hvac_mode: "heat"
    away_temp: 16
    precision: 0.5

to make it work from panel (to set the temp) maybe rules will help?!?!?!?

Did you got to implement the thermostat with the nspanel and tasmota?