NSURLErrorDomain -1200


I’m starting to have problems with my RPI 4 that I run HassOS on which I do not know what it is due to. Would appreciate input incredibly much.

It started a few months ago, when I received the following error message:

AN SSL error has occurred and a secure connection to the server cannot be made. NSURLErrorDomain - 1200

The only way to get it going again was to turn on the power. Then I had to try several times before I started to unplug the power.

I have had it upstairs where it has now become quite hot (25 degrees).

This started to come more often, so I tried to remove the shell on it, then felt that the wifi part was very hot. It got better without the shell, it did not hang as often.

I decided to move it down and connect it to TP cable (ran wifi earlier on it).

BUT last night I got the same error again.

Today I have no cooling on it, but just removed the shell, have ordered a fan to be mounted on it. I have also noticed that when it loses the connection and I pull the power, it is much faster in HA when it started up.

So my theory is that it:

1, Gets too hot and hence begins to hassle.

2, Been injured by overheating several times

BUT why do I usually get the error at night?

Am I on the right track? Anyone experienced the same problem?

I’m having this same issue!

It will run for a while but then begin to only be accessible from the local address/IP and not via the cloud. The app shows the NSURL -1200 error and I have to power cycle my RPi to get it to work again

Same issue since a couple of days…

I did not try to power cycle it but did you finally find a solution?

I haven’t found anything that works other than regularly power cycling which really sucks…

I found the solution. Mine has been damaged by overheating to many times. Bought a new one. The closedown at night had to do with my nexa powerplug which i though i had made an ”factory reset” on, but it was not reset, it was bind to my light automation, which turned on by sunrise.

So be careful with overheating, by an heat sink. As i was not fully informes of this, that rpi get overheated easy…

1 Like

Getting this issue as well
I have a heat sync so not sure that’s the problem?

Yes same issue but don’t think overheating is an issue. Anyone else seeing this?

i had issues with shelly, which i disabled as it was filing up my logs

I am using Cloudflare for DNS & Nginx as reverse Proxy. For SSL I am using Let’s Encrypt.