NTP time update

After I’ve changed NTP server that was set in timesync.conf file and restart my pi4, connecting to home assistant is not possible ( ip:8123 ). I can ping the device but I don’t have access using browser.
The reason I’ve changed NTP server was the system time is not correct and I hope with changing NTP things will go fine. Before changing NTP every time when pi4 restarts the date/time resets to the date/time of installation. In my case 13th of june. Now after changing the NTP server - no date. no time, no home assistant :frowning: Of course I tried to set NTP back but again there is no connection

Were you able to find a solution?

I am having the same problem here.

I switched to chrony for that and never looked back. The default ntp is difficult to troubleshoot imho

But “Chrony” is an add-on and, I suppose, it will only be available/start later in the boot. Are you using it instead of hassio “embedded NTP config” which is used during the startup or just to sync other devices on your network?

If I well understood, the problem mentioned on the first post by mrslv Miro is related to the startup configuration. I am having exactly the same problem.

I did not solve the problem in a nice way :frowning: I just reinstall and after that I am not touching those settings. I am not aware of how to change this settings in a secure way.
I wanted to change NTP to a local server to avoid problems when Internet is not available and time can’t be set by NTP. Unfortunately HA does not support HW RTC.


Did u solve this problem?
I solved very easy in my environment.
What I have done? In my env I have a rooter with openwrt installed, there I’m activated a ntp server which are listen on udp port123,
Then I change in the homeassistent OS in file /etc/systtemd/timesyncd.conf the line NTP=
I add first my internal rooter ip, in my case and I also keep the original entry but after my entry just a space between no comma separation no nothing like this:
Screenshot from 2021-11-09 21-44-10

Finally I reboot the machine(I cant find any way to restart the services…so I dont pull my hair only for this.
finaly I check the sync using the command: timedatectl timesync-status:
Screenshot from 2021-11-09 21-42-43

I hope this details can help u


Hi Marius,
Thank you very much for the assistance. At this moment everything is working fine at my place but I’ll do what you suggest in the first suitable moment (installing a fresh copy, for example :slight_smile: ).
Best regards,