NUC CPU temperature concerns

Hi All,

I’m running HA on an Intel NUC i7 (about 6 months old) and I notice the fan often runs and CPU temp is about 74⁰C at idle, often going up over 85⁰C when I so something like restart HA. The NUC is sitting on top of a cabinet in a cool room (currently the room is probably only about 15⁰C) so I’m worried that this CPU temp is far too high for the low load.
CPU usage is currently about 18%.

I’m wondering what other people are seeing as NUC CPU temps and what I should look at to reduce this. First thoughts are checking the heatsink paste which I will try to do this week.

This does sound like a little hot for NUC. Even for an i7. I suppose given the 6 months old that it is a gen8? What are you running on it? If it is HA on ubuntu then it is way too hot. I had a gen 6 idling at 46C under windows. Maybe look at removing the cooler and changing out the thermal paste?

1 Like

I have the gen 8 i7 (nuc8i7beh) and have a current idle temperature of 37. Running ubuntu and HA under docker together with 13 other containers.

Try update your bios if you haven’t allready and check your fan settings.

1 Like

Check setting in the bios as well, speedstep I think it was called.
In fact sit in the bios for a bit and see what it reports the cpu temperature as.

Thanks for the responses everyone. It is an 8th gen running Ubuntu, docker / HA (old hassio) with Motioneye add-on and a bunch of other add-ons like Google drive backup, gmusic, mqtt, assistant relay, ESPhome, VSC, Unifi controller, Node-red & Portainer (and a couple of others).

I’ll open up the NUC today as I bought some heatsink paste yesterday and will check bios too

Update: I replaced the heat sink paste and updated the BIOS firmware but the CPU temp still hovers in the same +80C range, basically at idle. While I was in the BIOS menu doing the update the CPU was only at around 40C but obviously this was with almost no load at all.

Currently the NUC is showing the below via SSH:

~$ sensors
coretemp-isa-0000
Adapter: ISA adapter
Package id 0:  +80.0°C  (high = +100.0°C, crit = +100.0°C)
Core 0:        +57.0°C  (high = +100.0°C, crit = +100.0°C)
Core 1:        +53.0°C  (high = +100.0°C, crit = +100.0°C)
Core 2:        +80.0°C  (high = +100.0°C, crit = +100.0°C)
Core 3:        +75.0°C  (high = +100.0°C, crit = +100.0°C)

What temp settings should I have for the fan control? currently they are just default but I’m wondering if these are no good… going to try it on ‘Cool’ mode or even drop the min. temp further yet. But I’m confused as to why it runs so hot in the first place. It was spotlessly clean when I opened it up, no dust at all

Because you have 2 cores very high and two at relatively reasonable temperature, I suspect that either your cooler is not sitting correctly on the CPU or that you have a defective cpu.
Do you consistently see those same 2 cores being high? Was this the case before you took out the cooler and replaced the TIM?

Its always run hot since I got it. I was very careful to put the cooler back properly when I replaced the paste this morning. I also changed the fan settings to try and bring the temp down, which it has a bit, but it’s still up around 65~85C all the time. Using the sensors command in SSH I see widely varying temps. I can refresh it within seconds and see temps 20C different…

Not sure these figures can be believed… (all taken within seconds)

sparkyhomeautomation@HA-server:~$ sensors
coretemp-isa-0000
Adapter: ISA adapter
Package id 0:  +65.0°C  (high = +100.0°C, crit = +100.0°C)
Core 0:        +63.0°C  (high = +100.0°C, crit = +100.0°C)
Core 1:        +54.0°C  (high = +100.0°C, crit = +100.0°C)
Core 2:        +67.0°C  (high = +100.0°C, crit = +100.0°C)
Core 3:        +57.0°C  (high = +100.0°C, crit = +100.0°C)

sparkyhomeautomation@HA-server:~$ sensors
coretemp-isa-0000
Adapter: ISA adapter
Package id 0: +100.0°C  (high = +100.0°C, crit = +100.0°C)
Core 0:        +64.0°C  (high = +100.0°C, crit = +100.0°C)
Core 1:        +57.0°C  (high = +100.0°C, crit = +100.0°C)
Core 2:        +97.0°C  (high = +100.0°C, crit = +100.0°C)
Core 3:        +62.0°C  (high = +100.0°C, crit = +100.0°C)

sparkyhomeautomation@HA-server:~$ sensors
coretemp-isa-0000
Adapter: ISA adapter
Package id 0:  +84.0°C  (high = +100.0°C, crit = +100.0°C)
Core 0:        +57.0°C  (high = +100.0°C, crit = +100.0°C)
Core 1:        +84.0°C  (high = +100.0°C, crit = +100.0°C)
Core 2:        +68.0°C  (high = +100.0°C, crit = +100.0°C)
Core 3:        +58.0°C  (high = +100.0°C, crit = +100.0°C)

sparkyhomeautomation@HA-server:~$ sensors
coretemp-isa-0000
Adapter: ISA adapter
Package id 0:  +70.0°C  (high = +100.0°C, crit = +100.0°C)
Core 0:        +68.0°C  (high = +100.0°C, crit = +100.0°C)
Core 1:        +67.0°C  (high = +100.0°C, crit = +100.0°C)
Core 2:        +70.0°C  (high = +100.0°C, crit = +100.0°C)
Core 3:        +68.0°C  (high = +100.0°C, crit = +100.0°C)

sparkyhomeautomation@HA-server:~$ sensors
coretemp-isa-0000
Adapter: ISA adapter
Package id 0:  +92.0°C  (high = +100.0°C, crit = +100.0°C)
Core 0:        +92.0°C  (high = +100.0°C, crit = +100.0°C)
Core 1:        +62.0°C  (high = +100.0°C, crit = +100.0°C)
Core 2:        +64.0°C  (high = +100.0°C, crit = +100.0°C)
Core 3:        +64.0°C  (high = +100.0°C, crit = +100.0°C)

sparkyhomeautomation@HA-server:~$ sensors
coretemp-isa-0000
Adapter: ISA adapter
Package id 0:  +67.0°C  (high = +100.0°C, crit = +100.0°C)
Core 0:        +67.0°C  (high = +100.0°C, crit = +100.0°C)
Core 1:        +56.0°C  (high = +100.0°C, crit = +100.0°C)
Core 2:        +61.0°C  (high = +100.0°C, crit = +100.0°C)
Core 3:        +57.0°C  (high = +100.0°C, crit = +100.0°C)

sparkyhomeautomation@HA-server:~$ sensors
coretemp-isa-0000
Adapter: ISA adapter
Package id 0:  +59.0°C  (high = +100.0°C, crit = +100.0°C)
Core 0:        +59.0°C  (high = +100.0°C, crit = +100.0°C)
Core 1:        +57.0°C  (high = +100.0°C, crit = +100.0°C)
Core 2:        +58.0°C  (high = +100.0°C, crit = +100.0°C)
Core 3:        +57.0°C  (high = +100.0°C, crit = +100.0°C)

sparkyhomeautomation@HA-server:~$ sensors
coretemp-isa-0000
Adapter: ISA adapter
Package id 0:  +87.0°C  (high = +100.0°C, crit = +100.0°C)
Core 0:        +63.0°C  (high = +100.0°C, crit = +100.0°C)
Core 1:        +60.0°C  (high = +100.0°C, crit = +100.0°C)
Core 2:        +63.0°C  (high = +100.0°C, crit = +100.0°C)
Core 3:        +87.0°C  (high = +100.0°C, crit = +100.0°C)

sparkyhomeautomation@HA-server:~$ sensors
coretemp-isa-0000
Adapter: ISA adapter
Package id 0:  +87.0°C  (high = +100.0°C, crit = +100.0°C)
Core 0:        +63.0°C  (high = +100.0°C, crit = +100.0°C)
Core 1:        +60.0°C  (high = +100.0°C, crit = +100.0°C)
Core 2:        +63.0°C  (high = +100.0°C, crit = +100.0°C)
Core 3:        +87.0°C  (high = +100.0°C, crit = +100.0°C)

sparkyhomeautomation@HA-server:~$ sensors
coretemp-isa-0000
Adapter: ISA adapter
Package id 0:  +77.0°C  (high = +100.0°C, crit = +100.0°C)
Core 0:        +67.0°C  (high = +100.0°C, crit = +100.0°C)
Core 1:        +64.0°C  (high = +100.0°C, crit = +100.0°C)
Core 2:        +75.0°C  (high = +100.0°C, crit = +100.0°C)
Core 3:        +66.0°C  (high = +100.0°C, crit = +100.0°C)

sparkyhomeautomation@HA-server:~$ sensors
coretemp-isa-0000
Adapter: ISA adapter
Package id 0:  +57.0°C  (high = +100.0°C, crit = +100.0°C)
Core 0:        +57.0°C  (high = +100.0°C, crit = +100.0°C)
Core 1:        +55.0°C  (high = +100.0°C, crit = +100.0°C)
Core 2:        +54.0°C  (high = +100.0°C, crit = +100.0°C)
Core 3:        +53.0°C  (high = +100.0°C, crit = +100.0°C)

sparkyhomeautomation@HA-server:~$ sensors
coretemp-isa-0000
Adapter: ISA adapter
Package id 0:  +93.0°C  (high = +100.0°C, crit = +100.0°C)
Core 0:        +93.0°C  (high = +100.0°C, crit = +100.0°C)
Core 1:        +71.0°C  (high = +100.0°C, crit = +100.0°C)
Core 2:        +92.0°C  (high = +100.0°C, crit = +100.0°C)
Core 3:        +66.0°C  (high = +100.0°C, crit = +100.0°C)

sparkyhomeautomation@HA-server:~$ sensors
coretemp-isa-0000
Adapter: ISA adapter
Package id 0:  +55.0°C  (high = +100.0°C, crit = +100.0°C)
Core 0:        +55.0°C  (high = +100.0°C, crit = +100.0°C)
Core 1:        +53.0°C  (high = +100.0°C, crit = +100.0°C)
Core 2:        +53.0°C  (high = +100.0°C, crit = +100.0°C)
Core 3:        +53.0°C  (high = +100.0°C, crit = +100.0°C)

sparkyhomeautomation@HA-server:~$ sensors
coretemp-isa-0000
Adapter: ISA adapter
Package id 0:  +73.0°C  (high = +100.0°C, crit = +100.0°C)
Core 0:        +73.0°C  (high = +100.0°C, crit = +100.0°C)
Core 1:        +56.0°C  (high = +100.0°C, crit = +100.0°C)
Core 2:        +73.0°C  (high = +100.0°C, crit = +100.0°C)
Core 3:        +70.0°C  (high = +100.0°C, crit = +100.0°C)

sparkyhomeautomation@HA-server:~$ sensors
coretemp-isa-0000
Adapter: ISA adapter
Package id 0:  +82.0°C  (high = +100.0°C, crit = +100.0°C)
Core 0:        +82.0°C  (high = +100.0°C, crit = +100.0°C)
Core 1:        +56.0°C  (high = +100.0°C, crit = +100.0°C)
Core 2:        +69.0°C  (high = +100.0°C, crit = +100.0°C)
Core 3:        +66.0°C  (high = +100.0°C, crit = +100.0°C)

sparkyhomeautomation@HA-server:~$ sensors
coretemp-isa-0000
Adapter: ISA adapter
Package id 0:  +65.0°C  (high = +100.0°C, crit = +100.0°C)
Core 0:        +65.0°C  (high = +100.0°C, crit = +100.0°C)
Core 1:        +61.0°C  (high = +100.0°C, crit = +100.0°C)
Core 2:        +49.0°C  (high = +100.0°C, crit = +100.0°C)
Core 3:        +50.0°C  (high = +100.0°C, crit = +100.0°C)

sparkyhomeautomation@HA-server:~$ sensors
coretemp-isa-0000
Adapter: ISA adapter
Package id 0:  +74.0°C  (high = +100.0°C, crit = +100.0°C)
Core 0:        +52.0°C  (high = +100.0°C, crit = +100.0°C)
Core 1:        +51.0°C  (high = +100.0°C, crit = +100.0°C)
Core 2:        +74.0°C  (high = +100.0°C, crit = +100.0°C)
Core 3:        +62.0°C  (high = +100.0°C, crit = +100.0°C)

Show us the ”top” command as well.

The hot cores seem to be moving around so it is either a gross physical problem or as @Cerb is suggesting, you have some rogue programs loading your CPU in pulses.

I had problem with NUC8i7 getting hot to 100C and fan was going max. The fix was: disable turboboost
To disable it, Enter the BIOS setup and from the System Utilities screen, select System Configuration. Then, navigate to BIOS /Platform Configuration (RBSU) > Performance Options > Intel ® Turbo Boost Technology and press Enter.

1 Like

I was curious to my CPU temp (never bothered before) so I checked it too. I’m on an older NUC3 with an Intel N3700 CPU. Running Ubuntu 18.04, HA, Supervisor, Motioneye (1x 720p can for now), unifi, adguard, vscode, influxdb, mariadb, node-red and deconz.

ha@ha-server:~$ sensors
acpitz-virtual-0
Adapter: Virtual device
temp1:        +58.0°C  (crit = +115.0°C)

coretemp-isa-0000
Adapter: ISA adapter
Core 0:       +55.0°C  (high = +90.0°C, crit = +90.0°C)
Core 1:       +49.0°C  (high = +90.0°C, crit = +90.0°C)
Core 2:       +47.0°C  (high = +90.0°C, crit = +90.0°C)
Core 3:       +47.0°C  (high = +90.0°C, crit = +90.0°C)

This is pretty constant even when I view the camera in Motioneye.

Intel quite a while ago change the TIM (thermal interface material) they use on the lid of the CPUs. They now use cheaper paste, apart from I think the big boy chips (I think).
But those two cores look rather hot, not sure what else you could do tho.

Did you tighten the heatsink screws the same amount ? Uneven pressure would cause a temperature difference.

Sorry but this is not what I would call a fix. It’s a recommendation I have seen from… Dell laptop users because their cooling is so abysmally poor that they have to disable performance features on their CPU to prevent them from throttling or overheating. This is absurd. Buy a $500 system to make it run like a $200 one because they saved $2 on their cooling engineering. (I have one and posted one such experience their forum too.)

2 Likes

System run normal after disabling, no cpu power loss. Turbo boost is creating big peaks on cpu load, temeperature to 100c and noisy fan, now I have a smooth running system. I am running debian os and zoneminder in docker.

No, you definitely have performance loss. Turbo Boost is designed to boost the CPU clock for urgent short term needs. The CPU has a built in period of time during which that boost is maintained and is normally calibrated in the BIOS. It is designed to do this with normal cooling and improve responsiveness and a very legitimate performance feature. Disabling it is like disabling a core out of four and say that because you don’t need the 4th core in a single threaded benchmark, you have no performance problem. It is abnormally poor cooling which is causing you to have temperature spikes and noisy fan. I never disable this on any of my PCs or NUCs. Never had temperature go above 60C under load with factory cooling. Except for the stupid Dell laptop for which I had to modify the cooling and managed to get the temperature down by 35C at idle. Turbo boost is on and under full load of 5min I never hear the fan.

2 Likes

I’ll look at the turbo boost to see what happens if nothing else. What I don’t understand is the temps being so high with CPU usage less than 20%

This is zoneminder livestream with turbo enabled, max power and quiet fan setting, but fan is going loud:

$ sensors
coretemp-isa-0000
Adapter: ISA adapter
Package id 0: +100.0°C  (high = +100.0°C, crit = +100.0°C)
Core 0:        +88.0°C  (high = +100.0°C, crit = +100.0°C)
Core 1:        +84.0°C  (high = +100.0°C, crit = +100.0°C)
Core 2:       +100.0°C  (high = +100.0°C, crit = +100.0°C)
Core 3:        +84.0°C  (high = +100.0°C, crit = +100.0°C)

acpitz-acpi-0
Adapter: ACPI interface
temp1:       -263.2°C  
temp2:        +27.8°C  (crit = +119.0°C)

iwlwifi-virtual-0
Adapter: Virtual device
temp1:            N/A  

pch_cannonlake-virtual-0
Adapter: Virtual device
temp1:        +77.0°C  

And this livestream without turbo, max power, quiet fan settings, nice quiet without to me noticeable cpu power loss:

sensors
coretemp-isa-0000
Adapter: ISA adapter
Package id 0:  +75.0°C  (high = +100.0°C, crit = +100.0°C)
Core 0:        +69.0°C  (high = +100.0°C, crit = +100.0°C)
Core 1:        +75.0°C  (high = +100.0°C, crit = +100.0°C)
Core 2:        +71.0°C  (high = +100.0°C, crit = +100.0°C)
Core 3:        +67.0°C  (high = +100.0°C, crit = +100.0°C)

acpitz-acpi-0
Adapter: ACPI interface
temp1:       -263.2°C  
temp2:        +27.8°C  (crit = +119.0°C)

iwlwifi-virtual-0
Adapter: Virtual device
temp1:            N/A  

pch_cannonlake-virtual-0
Adapter: Virtual device
temp1:        +68.0°C  

Both datasets are insanely hot. You have a cooling hardware problem. Again, what you are doing is equivalent of this: “My tooth hurts!- I have a fix: Pull them all out!”. Of course the hurting stops but you can’t use them to eat anymore.
My NUC runs below 45C idle and 75C under load (using stress) with ambient at 23C with everything enabled.

1 Like

You do not run idle zoneminder with 4 cameras up to 2K with modect

1 Like