NUC i3 : x86_64 generic - Observer:4357 connects, HA:8123 10.3 GUI does not

Had an Samsung EVO 970 m.2 SSD die this past week. Oh joy. Was able to snarf the most very recent backups off it before it went offline. Used Balena Etcher to load HAOS 10.3 haos_generic-x86-64-10.3.img.xz onto a spare SSD and plopped it into the NUC connected to the network. Let it boot, waited a bit, saw the Home Assistant CLI banner was displayed:

System information
  OS Version:           Home Assistant OS 10.3
  Home Assistant Core:  2023.7.1

  Home Assistant URL:   http://homeassistant.local:8123
  Observer URL:         http://homeassistant.local:4357

As these are the latest versions available, I still waited about 30 minutes before attempting to hit the generic URL. When I did, I got “unable to connect” errors from both Firefox and Chrome. :frowning: Waited still longer, still no joy. What is interesting, is the asteroids-like Observer URL:port would connect and display fine in both Firefox and Chrome.

All I want to do is see the generic first logon screen, so I can restore the backup. But not being able to connect is making it very difficult. Any suggestions will be appreciated.

The NUC is not on a static or fixed IP, but I do know the current IP address, and even trying is not working. :frowning: I haven’t even had an opportunity to restore the backup yet, because I cannot successfully connect to the GUI.

DNS resolution is working, because using http://homeassistant.local:4357 succeeded. My router and a DOS/CMD nslookup and ping all return the same IP address.

If the Observer connects and works, why not the HA GUI/Login itself?

Refresh your browser ctrl-f5. If this does not work make certain no other past instance of HAOS is running anywhere and there are no IP reservations on the MAC address of your system.

Thanks for that suggestions. CTRL-R and CTRL-F5 did not make any difference, nor did clearing what little browser cache (<100K) existed. There is no other instance of HAOS on the network, nor are there any IP reservations or DNS/DHCP definitions related to HAOS or the IPv4 address.

Which makes me wonder, if I used an IPv6 address, would it connect? :thinking:

If you do not mind could you try my install guide for bare metal. Also have for VM in case in the future is of use.

1 Like

I did take a tip from your install guide, to login and use the netstat command, and grep for tcp connections. Right there, clear as can be, port 8123 is NOT OPEN. Looks like I get to re-write the SSD and try again for some undetermined reason.

Check the monitor on theHA installation itself.

Details or a link to the files and/or commands would be helpful
If you mean the output of the command host logs nothing helpful appeared there.

Well, writing the HAOS 10.3 image to the SSD again seems to have resolved the issue. Just hit port 8123 with the browser, and uploaded the backup tar file. Should be back online in another hour or so.

or so . . . (restore is still going, four hours later)

It’s four hours later, and the restored system is still not available, yet. :frowning: Performed a supervisor logs command to see what’s going on, and then a login and netstat -a | grep tcp. Details in the screenshots below. My laptop is still connected to the restore window from the HA GUI, but it is NOT shown in the netstat output. Unfortunately, port 8123 is still not open, yet. I’m going to let it play out overnight. If there’s no change, then I’ll do a hard shutdown on the system and reboot it to see what MIGHT happen.

Just to confirm my understanding, you can access HAOS using the webUI following a new install. However, once you start restore you loose access to port 8123. If my understanding is correct, I believe you need to look in configuration.yaml. Otherwise something in your backup is causing such behaviour.

In the later case, the only salvation is to possibly manually rebuild your system from scratch.

Was the host computer IP the same as before you reinstalled Home Assistant?

I had a very similar issue a few days ago, discussed here.

Forget the UI for a moment. Can you determine if any automations are running? In my case a PIR sensor was turning on the associated light. My CGM monitor was displaying data correctly. And other automations that appeared to work, but no UI.

Two external services are successfully connected:
1} Logitech Media Server
2) Alarm Decoder Interface

This backup was automagically created before updating to HA 2023.7.0. The system was running and successfully restarting at that time. I presume the configuration.yaml file is okay. If there were an issue in the file I would expect to see it in the core logs.

What the core logs show is HA is not able to load missing integrations. This is expected as it was only a core backup. IFF the UI ever becomes ready, I can re-configure these integraions. But it never came up overnight. These four integrations are all showing status: Retrying in backgound

  • nut
  • octoprint
  • Whisper
  • Piper

Then nothing else shows up. It’s as if they are blocking instead of backgrounding?

When there was nothing new this morning, I did a power-down restart, and this is the current status:

IMHO best way to troubleshoot is to connect the HAOS box directly to a DHCP server (change your IP address if static to DHCP) bypassing SSL or any other DNS related service which might disrupt HAOS. Basically connect to a LAN which is simple and free of any firewalls.

Another way of achieving a clean setup is to connect to a simple Ethernet switch your HAOS and desktop systems using a fixed IP address. This setup will bypass everything which might be blocking system access. If the issue is still no access to HAOS time to think if you should start from scratch.

1 Like

I do believe you are correct. I have my configuration.yaml and esphome yaml and other config files extracted from the backup. Just start clean and add things back, in layers.

It’s hours later, and I’ve re-written the m.2 SSD for the third time this weekend. Started restoring all my ESPHome devices and outdoor lighting automations first. It’s going to take a few more days to get anywhere near where my system was formerly. :frowning: The good news is, it gives me an opportunity to better design and layout my dashboard pages. :slight_smile:

Sunday evening: New HAOS 10.3 image, default Home Assistant deployment, initial configuration, ESPHome restored
Monday evening: key daily automations restored, Mosquitto MQTT restored, RTL433 restored
Tuesday evening: All sensor definitions restored, Mosquitto configured and running, RTL433 configured and running

Now, it’s just a slow process of catching up. Mostly automations and troubleshooting/tweaks. Tonight, the Sonoff USB stick for Zigbee went offline, and would not come back online. Go figure.