NUC10 install with NVME SSD

Not sure is it the right place to post it, but it took me a day to figure out as by default NVME SSD means that default install did not work (USB+BalenaEtcher NUC ISO to SSD).
And solution took 15 minutes with downloads…

I spent too much time to get it work. I had small Pi 8” display attached to NUC and no mouse, so Etcher did not show the SSD and although there is an option to display all drives there was no way to reach it.

This was my solution that worked

  1. Live Ubuntu desktop install
  2. Got USBImager
  3. Downloaded NUC image from official site on Ubuntu
  4. Using USBImager I installed Home Assistant ISO to SSD

Restarted and it worked

Access the Home Assistant via console. To log in to the physical console the username is root, with no password.

If anyone can give me hint how to change the password/user in console to make it safer I would appreciate the help!

Hi man!
Trying to flash my internal SSD with USBimager right now. I created one big partition formatted in Ext4 and deleted everything on it. How did you manage to make the SSD selectable within the USBimager?
Sadly it doesn’t show up and I can’t figure out why


This method works great: