NUT not working with nut-client

It seems that the nut sensor requires the actual nut-server to work. Any thoughts of making it work with the nut-client? I have my nut-server installed on a different RPI. My HA RPI is stressed out enough. My HA RPI has the nut-client installed and is monitoring the nut-server RPI. the upsc APC@fsdns command (APC@fsdns is the name of my UPS on server fsdns) works fine. But as expected the upsc -l command returns a connection error since it’s expecting a hostname.

Does the host parameter of the nut sensor not work as expected? You should be able to specify either hostname or ip address of the nut server here.

Yes that works as expected. It would be nice though if it took advantage of the nut-client installed on the local server instead of querying back across the network for data from the server. When you think about it, even the server itself has the nut-server and nut-client installed.