NUT Server Integration on Home Assistant Core 2022.6.5

I have recently upgraded HA to 2022.6.5 Core. It is running in Docker on Synology NAS.
I noticed my UPS monitoring stopped. I removed the NUT Integration and attempted to reinstall it. However I get this error

The NAS config looks OK as I can SSH to it and the info

Init SSL without certificate database
battery.charge: 100
battery.voltage: 13.50
battery.voltage.high: 13.00
battery.voltage.low: 10.40
battery.voltage.nominal: 12.0
device.type: ups blazer_usb
driver.parameter.pollinterval: 5
driver.parameter.port: auto
driver.parameter.synchronous: no
driver.version: DSM7-0-1-NewModel-repack-42200-210809
driver.version.internal: 0.12
input.current.nominal: 2.0
input.frequency: 50.0
input.frequency.nominal: 50
input.voltage: 241.4

Use ip address from nas

No luck with NAS IP address

The NUT Integration appears to be broken on 2022.6.5 and 2022.6.6.
I rolled back to version 2022.3.8 and it works fine. I’m running Docker on Synology

It works here

ip server
nut user
nut pass

I don’t use NUT addon.

Only a external NUT in docker.

I’ve been trying to get the NUT integration working (have never tried or had it running before now). I get the “failed to connect”, and also can confirm the DSM 7 NUT server is working fine via SSHing to the NAS as mentioned above.

I’ve tried every combination of IP address or host name, ports 5000 and the default, and all sorts of credentials: my Synology login, ups/monuser, ups/secret, etc… but no luck.

I can’t add a NUT user as I’ve seen some loose guides refer to because the upsd.users file doesn’t exist where I should supposedly see it.

What makes it even more frustrating is the integration form resets on ever failed attempt!

Has anyone had any luck?

It’s been a while. Running to the same problem.
Did you ever got it working. User config file missing and every combo not working

No, sadly not. Eventually abandoned it when I realised I spent more time than there has been total power outage in my life.

I’ve also been troubled by this issue, and I’ve tried many possibilities, including the NAS IP, different usernames and passwords. Finally, I found that you need to add the IP address of the HA container to the UPS allow list in DSM. In addition, you need to open port 3493 on the NAS firewall. Everyone can try this and see if it works.
螢幕擷取畫面 2023-10-26 225118