Occusim broken?

I can’t get OccuSim to work. Stripping it down to the most simple config still fails:

2018-02-04 22:37:38.125506 WARNING AppDaemon: Traceback (most recent call last):
  File "/usr/lib/python3.6/site-packages/appdaemon/appdaemon.py", line 1651, in read_app
    self.init_object(name, class_name, module_name, self.app_config)
  File "/usr/lib/python3.6/site-packages/appdaemon/appdaemon.py", line 1446, in init_object
  File "/config/appdaemon/apps/occusim.py", line 32, in initialize
  File "/config/appdaemon/apps/occusim.py", line 65, in create_events
    start = self.parse_time(start_p)
  File "/usr/lib/python3.6/site-packages/appdaemon/appapi.py", line 274, in parse_time
    return self.AD.parse_time(time_str, name)
  File "/usr/lib/python3.6/site-packages/appdaemon/appdaemon.py", line 972, in parse_time
    parts = re.search('^(\d+):(\d+):(\d+)', time_str)
  File "/usr/lib/python3.6/re.py", line 182, in search
    return _compile(pattern, flags).search(string)
TypeError: expected string or bytes-like object

My config

Occupancy Simulator:
  class: OccuSim
  module: occusim
  log: 1
  notify: 1
  enable: input_boolean.vacation,on
  test: 1
  dump_times: 1
  reset_time: 02:00:00
  step_evening_name: Evening
  step_evening_start: 18:32:00

  step_night_name: Night
  step_night_start: 11:00:100:

It really doesn’t like sunset or sunset - 00:45:00 as a start time either

try putting the times between dubble quotes like “11:00:00”

Thanks, as it happens I worked that out an hour after I posted but went to bed! The examples and documentation is all over the shop and misleading.

e.g. https://github.com/acockburn/occusim/blob/master/appdaemon.yaml.example

that happend by the appdaemon updates.
i know that andrew would be happy if you would make a PR to change it or to raise an issue with all parts that are not right anymore.

glad you worked it out.