Odroid C2, HassOS, setting up HassOS AP.. wlan0 missing?

I’m trying to run the Hass.io Access Point plugin.
Unfortunately, the USB WLAN stick I’m trying to use is recognized by lsusb, but no interface is assigned to it, even after a full reboot. I searched around a while and tried a few options I found (such as trying nmcli), but always get “no wi-fi interface found” or “wlan0 does not exist”.

Note that I want to run the wlan stick in parallel, not to replace my ethernet connection.
Anyone have any idea what else to try?

Okay… apparently it doesn’t like that specific wlan stick. Another one worked instantly.

It will be helpful if you mentioned the USB WLAN stick you’re using.
With the chip model it will be possible to find whether its config is enabled on linux kernel or not and whether it is supported in linux kernel used by the Image you used.

It’s a completely generic chinese stick I got ages ago for a Raspberry Pi 1.
Windows reports it as: Realtek RTL8188ETV Wireless LAN 802.11n USB 2.0 Network Adapter
I’m running Home Assistant OS 6.5 on an Odroid C2.

That one is normally supported in the kernel (at least on Debian and Raspbian)

I tried it out on a PC (running HAOS via Proxmox) and it also doesn’t see wlan0 (passed through from Proxmox, of course). Just swapping the stick for another (also Realtek, but different chipset I think) made it work on the Odroid, at least… on the PC, none of them are recognized.