ODROID C2 open issues

Hi Hassio community, I switched from RPI 3 B+ to odroid C2 as it offer the possibility to use eMMC card and it seems to improve the system read write access.
So far so good and the switch was easy using my last snapshot.
For the moment the open points are :

  • The temperature of the CPU is not reported or I didn’t find the correct way it is reported.
  • I can’t find the correct USB port where the RFLINK is attached
  • The SSH and Web Terminal is not starting without any log information

I propose to have this topic to follow all open points for ODROID C2 and get all workarounds in one place.
Any support or ideas for the open points mentionned are welcome.

1 Like

I susgest you ask questions on the C2 on the Hardkernel odroid forum as well.
The Hardkernel odroid wiki has a lot of useful info , that will help you get all the CPU info etc.
You didn’t say which OS you are running on the C2, IMO ubuntu18.04 is a PITA, and I have gone back to ubuntu 16 on mine.
For example setting up the remote control with LIRC is problematic, I could use more exact terms but that would break the forum rules. Systemd is fussy how you use it , and much more.
The major problem is most of the applications are written for use with kernel-4, and the is no much backward compatibility with ARM devices, the image on the repos for the C2 uses kernel-3.
I have odroids C1+,C2 & XU4.

I’m using a UX4 with Ubuntu 18.04. Try cat /sys/devices/virtual/thermal/thermal_zone*/temp. The first four numbers should be each of the cores and the last number should be the GPU.

Thank you for your feedback.
I am using the hassos image from this link : https://github.com/home-assistant/hassos/releases/download/2.2/hassos_odroid-c2-2.2.img.gz.
I am not sure hardkernel team can support as this distribution is very specific to Home Assistant.

If I look for any “therm” related folder or file I have nothing that could help :
core-ssh:/# find / * |grep therm


In glances, it is “soc_thermal 1”

Hi Froz, this is unfortunately not working :(.
Thank you for supporting.

How are you trying to get the CPU temp? I’m using glances with a tweak to support Odroid, but I don’t see why a command line sensor couldn’t also be made to work.

Hi Froz, I tried with this sensor :

- platform: command_line
    name: CPU Temperature
    command: "cat /sys/class/thermal_zone0/temp"
    unit_of_measurement: "°C"
    value_template: '{{ value | multiply(0.001) | round(1) }}'

When I check the hardware in hassio menu I have :

  • serial:
    • /dev/ttyS1
    • /dev/ttyACM0
    • /dev/ttyS2
    • /dev/ttyS0
    • /dev/ttyS3
    • /dev/ttyAML0
  • input:
  • disk:
  • gpio:
    • gpiochip14
    • gpiochip0
  • audio:

It is strange as my zwave key is working properly and attached to /dev/ttyACM0. But when in the terminal I check which tty I have on /dev I have only /dev/tty. I probably missed something.

When I detach and reconnect the usb from the Rflink I have this line :slight_smile:

[ 2947.189090] usb 1-1.4: USB disconnect, device number 7
[ 2953.042667] usb 1-1.4: new full-speed USB device number 8 using dwc2

How is it running so far? I am currently running openhab on the Odroid C2 but I am thinking about switching over. HassIO seems to make the installation really easy, I am currently checking it out on a Pi2. I don’t care much about the cpu temperature as I put a passive cooler on it.
SSH however I definitely require - do you figured out why it is not running?

It is running much more better on C2 compared to RPI2. I think it is mainly due to the emmc. Ssh addon is running but not the ssh+terminal add-ons. Switch from RPI to C2 was easy : just recover the backup without the system stuff and then reinstall each add-ons.
Hope you will switch to increase the Hassio C2 users :slight_smile:

Try “cat /sys/class/thermal/thermal_zone0/temp” I’m not using Hassio so I can’t test it in that environment.

I am using a C2 with an external drive running DietPi, homeassistant, mosquitto, mariadb, glances, and syncthing. It is almost idle. I previously used an RPI 2B+ and it was swapping a lot as well as CPU bound. The C2 has a few quirks, but it has been a very nice upgrade. I may get around to using an emmc, but so far I haven’t felt the need to do so.

Thank you for your feedback. I confirm I tried it already:

core-ssh:/# cat /sys/class/thermal/thermal_zone0/temp
cat: can’t open ‘/sys/class/thermal/thermal_zone0/temp’: No such file or directory

Hi there,
Did you try upgrading to the new 5.x OS version?
My Odroid C2 won’t book a 5.8 or 5.9 OS when running from eMMC. It works fine on an SD card though.

Thank you

Same here! Where you able to boot from an older image?


OK, managed to boot using the 4.20-image. But, as soon as I upgrade to the latest 5.x release, it will no longer boot.

Same problem here as well! Odroid C2 won’t boot from emmc…
4.15 is booting from emmc. Upgrading to latest HA OS also works as long as you don"t reboot… I’ll try to post a picture of the booting sequence tomorrow. Hope it can be fixed somehow :slight_smile: