ODROID / HA Not Appearing on Network

I am at a total loss here, I just purchased a preloaded ODROID from ameridroid and set it up and did some updates and now it is not appearing on my network at all and http://homeassistant.local:8123/ isn’t working. How do I completely flash this thing and start over? Or should I return?

I was having this issue and followed this tutorial: SOLVED! Home Assistant Blue (New) instalation and errors, help for a newbe - #11 by Brenen

sorry i can’t help you with homeassisatnt blue or odroid but in the worst case i think u could reinstall / reflash it:
ODROID - Home Assistant (home-assistant.io)

Did you ever get this working @Brenen ?

I tried to upgrade mine when I got it and it ended up bricking the thing. With some help from these forums, doing a flash turned out to be easy.

FLashing the Odroid

You’re going to need:

  • a micro USB cable… one that isn’t 10 years old you dug out of a drawer somewhere. I say that because my efforts to flash were frustrated by using a crappy cable. A new one from amazon basics worked like a charm.
  • An allen wrench to open the case
  • Balena Etcher to write the firmware

How it works is that there’s a little switch you can flip inside the case that makes the Blue look like a drive to windows. You flip the switch, booth the device, write the firmware with Etcher, then flip the switch back again so it boots normally into HA.

The whole thing is easy once you have a decent cable and understand the SPI switch.

Ya I got it, it turned out to be a bad cable which completely died during update, which bricked it. I was able to flash it and it’s working now but not under homeassistant.local