Odroid N2+ Flashed emmc/sd - not properly unmounted

Can’t get this thing going out the gate… It shouldn’t be this hard! Stuck on step 1. Flash the emmc or SD card with proper image and boot.

Brand new Odroid N2+
“Red Dot” emmc ( I have an 8gb and 2x 16GB to play with )
16BG SD Card

I believe I succeed flashing an image on to the EMMC/SD card. I have tried the following:

-Write emmc image using Balena Etcher using Win10 ( using the usb3.0 emmc module writer )
-Write SD card image using Balena Etcher using Win10
-Write emmc image using Balena Etcher using Ubuntu Box ( using the usb3.0 emmc module writer )
-Write emmc image using Balena Etcher using Win10 -Odroid as a USB device.

I flash the emmc with BalenaEtcher. Success. I then install and power the Odroid. In every case, at some point during bootup I get the message… “XXX not properly unmounted. use fsck - data may be corrupted.” Eventually I will get the CLI command line. However I am only able to see the Home Assistant thru my local network in one case and it fails to install software ( endless loop ). in all the other cases it wont even let me see it at all over the network.

It has to be a problem flashing the drive, ejecting the USB writer or a bad image? There are no other steps to do.

I am made a big assumption that the USB writer is not properly shutdown after flashing ( why it says not properly unmounted? ) so i have been focusing my efforts here.

Win10 hated the emmc after flashing - going on about unformatted drives. I ignore windows requests to format and eventually find a way to eject the drive.

Since Win10 isn’t playing nice… I switched to Ubuntu to flash and follow the process again. I unmount everything and eject.

Doesn’t matter what I do. Any ideas?

I flashed mine directly like this and it worked 1st time using windows 10:

Did you get any prompts from win10 after the flash was completed about drive letters which needed formatting?

The only thing I realized i did different from those instructions was downloading the image from Github and not the file directly linked from the guide you included. Which I then tried… with the same results.
Hell I even formatted the drives after just for fun.

Once I failed install is on the emmc do I need to prep the card ( erase, format ) before I reflash for a second go?

I’m not an expert but I think the format dialogs are because windows doesn’t recognise the Linux format so should be ignored.

That said, when I flashed the odroid with usb, not flashing the card, it went as the instructions said, and I just unplugged after flashing and flicked the switch back.

I don’t think you can format the card for Linux in windows, just need to flash the .bin again.

Well… it’s working.

The fix:

I gave up on the O-droid-N2+ for a moment. Maybe my hardware is broken?

So to test this, I instead installed HA on a Win10 virtual machine ( followed the win10 instructions ). I ended up with yet a different error. “system not ready with startup state: setup”. I searched this in the forums and discovered a thread. ( sorry I wasn’t able to link the thread - it’s easily found with the above as a search term )

The conclusion in the thread… Home Assistant doesn’t like my Netgear R6220. The fix in the thread? Custom firmware for the router!


I dug my O-droid N2+ back out, plugged it directly into my modem’s available ethernet port (not my Netgear R6220) and it runs just fine! First try.

No clue given why the HA wont play nice with the R6220. You would think this type of issue would be referenced in a troubleshooting guide.

I will NOT be adding custom firmware to my router - this should not be the solution. HA is already a handful, the last thing I need is to add more variables. I’m sure I have a second router around I can use for a dedicated HA network… seems a better option.

Anyway hope this helps another person!