Odroid-xu4 HA image not booting


I tried HA by running it as a VM on my laptop, and want to have it running permanently now on my Odroid-XU4, but the HA image I downloaded does not boot. (I flashed the image on the emcc memory card)
I had this same problem with an older version of the HA Odroid image, I never got it to boot.
To verify that the problem is not on the Odroid, I downloaded and flashed a Ubuntu image from the Odroid site, and that one booted without any problems.
Also, when I put the emcc memory card in my laptop, it mounts, and I can see its contents.

Can someone help to get HA running on my Odroid ?
I took the Odroid, because it is supposed to be faster than the pi3 and the emcc memory is supposed to be much more reliable than normal flash memory.

Hi there, did anyone get back to you on this?

I have an Odroid C2 which was running fine on 4.x which after upgrading to 5.x stopped working.
I tried flashing the eMMC with a fresh 5.9 and 5.8 and it wouldn’t boot, however it works fine on a SD card. I then tried a fresh 4.x on the eMMC and this works fine.

Your question comes just in time.
Yesterday, I did some additional googling, and I found some instructions to boot from emcc, and it worked, my xu4 is running for about 24h on emcc now.
To do the commands, I connected a USB keyboard and a HDMI TV to the xu4 device
After startup, I logged in using root as login without password, this brings you to the ha command line, and then go to the linux command line by typing login.

This is what i did to make it work:
Based on this link, and using the latest xu4 image file.

    flash HassOS to both an SD and eMMC, 
    then boot off the SD with the eMMC also plugged in, then run
    dd if=/dev/mmcblk1 of=/dev/mmcblk0boot0 bs=512 skip=1 seek=0 count=16381
    at the Linux prompt. 
    At first dd was not able to copy the bootsector because the emmc memory was read only,
    to make it writeable:     echo 0 > /sys/block/mmcblk0boot0/force_ro
    to re-enable after running dd: echo 1 > /sys/block/mmcblk0boot0/force_ro
    shutdown, poweroff and remove the SD card.
    Power the xu4 again, and it now boots from emcc.

I changed the IP@ of my Home Assistant VM, and will keep it around to test new things before I put them on the xu4.

Seems like a painful process.
I think I’ll wait for a bit and see if they fix the problem in version 6.x

Not painfull at all, just copy/paste the 2 commands,
to copy the bootsector from the SD card to the emcc card.
It only takes a few seconds.
And if it does not work for you, you can always wait for the next version.

The hardest part was to find this procedure.

Actually, I think that only works for XU4 devices. C2s don’t have a boot sector like the XU4.
I think the problem here is a different one.

As I don’t have a C2 device, I cannot test it, but when I look at the odroid website, I see that the C2 also has SD and emmc slots, but instead of a manual switch, there seems to be a process in firmware that automatically chooses sd or emmc to boot.
But you will still need a bootsector to be able to boot.

So why not just test it, if it fails, you can always reflash your emmc card if something goes wrong.

Exactly this two lines didn’t help, but this docks does

Hope it would help someone