Official SmartThings Integration: Error Config flow could not be loaded: 500 Internal Server Error Server got itself in trouble

I have HA OS installed on a Chromebox and it is working great. However, when trying to install the official SmartThings integration I get:

" Error

Config flow could not be loaded: 500 Internal Server Error Server got itself in trouble"

In the logs, this always comes up when I try to install the plugin:

Logger: aiohttp.server
Source: helpers/
First occurred: 9:38:32 PM (1 occurrences)
Last logged: 9:38:32 PM

Error handling request
Traceback (most recent call last):
  File "/usr/local/lib/python3.9/site-packages/aiohttp/", line 435, in _handle_request
    resp = await request_handler(request)
  File "/usr/local/lib/python3.9/site-packages/aiohttp/", line 504, in _handle
    resp = await handler(request)
  File "/usr/local/lib/python3.9/site-packages/aiohttp/", line 117, in impl
    return await handler(request)
  File "/usr/src/homeassistant/homeassistant/components/http/", line 60, in security_filter_middleware
    return await handler(request)
  File "/usr/src/homeassistant/homeassistant/components/http/", line 98, in forwarded_middleware
    return await handler(request)
  File "/usr/src/homeassistant/homeassistant/components/http/", line 28, in request_context_middleware
    return await handler(request)
  File "/usr/src/homeassistant/homeassistant/components/http/", line 79, in ban_middleware
    return await handler(request)
  File "/usr/src/homeassistant/homeassistant/components/http/", line 219, in auth_middleware
    return await handler(request)
  File "/usr/src/homeassistant/homeassistant/components/http/", line 137, in handle
    result = await result
  File "/usr/src/homeassistant/homeassistant/components/config/", line 132, in post
    return await super().post(request)
  File "/usr/src/homeassistant/homeassistant/components/http/", line 62, in wrapper
    result = await method(view, request, *args, **kwargs)
  File "/usr/src/homeassistant/homeassistant/helpers/", line 72, in post
    result = await self._flow_mgr.async_init(
  File "/usr/src/homeassistant/homeassistant/", line 203, in async_init
    flow, result = await task
  File "/usr/src/homeassistant/homeassistant/", line 230, in _async_init
    result = await self._async_handle_step(flow, flow.init_step, data, init_done)
  File "/usr/src/homeassistant/homeassistant/", line 325, in _async_handle_step
    result: FlowResult = await getattr(flow, method)(user_input)
  File "/usr/src/homeassistant/homeassistant/components/smartthings/", line 61, in async_step_user
    webhook_url = get_webhook_url(self.hass)
  File "/usr/src/homeassistant/homeassistant/components/smartthings/", line 113, in get_webhook_url
    return webhook.async_generate_url(hass,[DOMAIN][CONF_WEBHOOK_ID])
  File "/usr/src/homeassistant/homeassistant/components/webhook/", line 73, in async_generate_url
    get_url(hass, prefer_external=True, allow_cloud=False),
  File "/usr/src/homeassistant/homeassistant/helpers/", line 116, in get_url
    raise NoURLAvailableError

Figured it out. I needed to set my external url in Configuration > Settings > General to point to my duckdns URL for my HA instance.

This is the exact same issue I am having!

However when I go to Configuration > Settings > General I don’t have anywhere to put my URL for extermal Nabucasa link can you screen shot yours or tell me an alternative way to do it?

Here is where I do it in HASS OS. Here is documentation on where to set it in the config: Setup basic information - Home Assistant

Good luck!

Ive got this issue.
Totally new to HomeAssistant and running it on a VM. I really have no clue how to solve this and ive tried to follow all the advice ive read with no luck.
Anyone able to give me an idiots guide please.


1 Like

I have the same issue, but since i have nabu casa, the external name is controlled by that.

Same issue here as Geekoam. I’m getting the error “Config flow could not be loaded: 500 Internal Server Error Server got itself in trouble”.

I have Home Assistant running well on a VM and I’m currently running the NabuCasa trial. I can’t see a way of configuring it as shaxs did.
I have Smartthings hub v3 connected via ethernet and working well via the app and via Google Home.

1 Like

Also New HA and am get this message
" Error Config flow could not be loaded: 500 Internal Server Error Server got itself in trouble"
when trying to integrate Smartthings. Has anyone found a solution?

Update #2: fixed… there was a thread on Reddit that said to install the samba addon and remove “smartthings” file from .storage

Keep in mind it’s a hidden file so if your looking it up in Windows then you’ll have to show hidden files so you can see the .storage folder. Once I did that everything went smoothly.

Update #1: logging into the remote ui from nabu casa I can go to the “manage” of the SS webhook. I can’t change it if course but it shows a string after the url which may or may not be interfering… I don’t see the integration in the list nor the devices but one of my Samsung tvs shows up in the integrations list.

Original post:
I’m in the same boat with the 500 error and NabuCasa. Would love to get this figured out to use my SS motion sensors


Found the solution here: Home Assistant.

Close down HA, delete config/.storage/smartthings, restart HA and follow the SS config.


Update. Sorted it.
Deleted the whole .storgae folder
Switched off remote access, deliberately started it again with wrong url - this threw a fault.
Deleted my smartthings access token.

Re logged into remote correctly with correct external URL.
Started the instal again and it worked

Where did you find this reddit?
I cant even find the .storage folder. Im using a mac to access my HA over a VM.
Any advice? Sorry totally new to all this

I am running Core on a Synology in package mode.


On macos you can show hidden folders and folders by using shift+cmd+. in finder

Unimaginable, I ran into this yesterday with latest Home Assistant 2023.4.5 release, guess it is still not fixed.

I am using iPad Pro+Chrome browser. Where can I find the hidden config/.storage file??