OKOK Bluetooth scales

Hi I have a Bluetooth body scales that link to the “OKOK international” app they run Bluetooth only and would love to get a Bluetooth service for it to link to home assistant I have passive BLE integrated and setup but doesn’t pick it up at all nothing has to be honest just my mobiles Bluetooth via the OKOK international app

Hi, I just ordered one and just saw your post. Did you finally managed to do it ? I’m interested if someone succeeded.

I have bought the scale as well. Experimenting at this moment. Hopefully we can get it connected :slight_smile:

I see there is now an integration for OKOK scales here:

Has anyone tried it yet?

Hello,

I installed the custom repository, restarted HA and started the OKOK Scale integration but it says No devices found.

Trying to connect via a Bluetooth proxy (ESP32-POE-ISO-EA). Other Bluetooth devices do work and i am also able to connect to the scale with the OKOK app on my iphone.

Tried to remove it from the app and also to connect while standing next to the ESP, but doesn’t work yet.

Any ideas?

I have the same issue but I got the ‘‘Config flow could not be loaded: 500 Internal Server Error Server got itself in trouble’’ error

@stephan3 maybe try standing on the scale to wake it up?

Thanks Matt,

I tried that, this morning but no response.

1 Like

Yeah I have contacted the developer and he fixed it, it was a bug. It works for me now. Can you try again? I also have read that you need to deinstall the app because it interferes the connection.

I de-installed the app and disabled bluetooth on my iphone but the scale still doesn’t appear in HA. I enabled debug logging and checked if i can find the mac address but no.

The scale appeared in Home Assistant!

2 Likes

Yes, Im happy for you :tada: :tada: :tada:

1 Like

How did you find the scale in Home Assistant. Could you describe the process you carried out?