Old Amazon Fire Support

First off, I am truly grateful for the support I see on this forum. The team here is responsive and knowledgeable. I have learned a lot just by reading through the questions and answers.

I have a very old Kindle fire (circa 2016) that I’d like to up-cycle as a dashboard for my son’s room, and Amazon apparently is not providing OS updates for these devices.

The home assistant app does not show up on the store for this device, although I can see it on my computer through the web, it shows my device in red.

I tried side-loading the minimal version from APK mirror, I can log in but then I get an almost blank screen , I assume this might be the webview issue discussed here. I am able to load the page via Silk and Fullykiosk (although it complains about webview and runs very slowly)

Just wondering if there are any options getting the app running on an old Fire?

Would installing the play store solve this? I have not tried this yet.

if you cant get past the login screen then it is a webview issue that the app cannot solve

1 Like