On boarding page 2

Hi newbie here just installed hassio on raspberry pi 3 b+. Connected to network , updated and all ok.
Most install instructions don’t show the registration pages.
So create name and password all good.
Move to next page where you put in name of home, location and units. It just says fail
I’ve rebooted pi and tried different browser still stuck on same?
What’s wrong?

Many thanks if someone can point me on the right dirrection

I’m not exactly sure where HA goes to retrieve the map/location information but from the looks of it I’d say that that service is down right now for some reason.

You can either check back later and try again or you can skip it altogether and manually update it later in your configuration.yaml.

Hi thanks for quick answer it does pick up a close location well 60 miles away and then I drag to my location.
However how do I bypass that step?

Don’t use Edge browser

Is there not a “next” button at the bottom of the screen?

Yes the next button just produces the fail code.

Please try with literally any browser but Edge…lol

Managed it now.
Tried login with ipad app and got past name,location page.
Now can login normally.
I normally would not use edge but as it wasn’t working in firefox tried another browser… and it wasn’t an edge problem.
Thanks for responding will be asking more questions soon!