[On Hold] Deprecating Home Assistant Supervised on generic Linux

It’s not much but here are the non-HA/non-add-on containers I run in docker.

if anyone wants my “docker run” commands for them I’ll be happy to post them up or PM. Most of them I’ve gotten from the forums anyway.

1 Like

is there any alternative ? the path they have chosen last few months is nothing i want to be associated with.


I run the NUC image as my main Home Assistant server however before I left home for a year I set up a backup Home Assistant server in case of hardware failure.

I tried for days to get the NUC image to recognise my network card on the backup pc without success. The advice then was to use Home Assistant supervised on a Linux OS. This worked first go.

I have since seen many, many people be given the same advice.

I hope you are prepared for an increase in support requests for the officially supported NUC image.

Or will that be next the next option dropped because it causes too many issues?


Can you clarify the prerequisites for Proxmox? I watched an installation video which stated a minimum of two drives are required, one dedicated for the hypervisor and the other for images and virtual machines. In fact, the video recommended three drives, in order give the virtual machines their own drive.

Is it possible to run it all on one drive?

I’m confused by this. Isn’t the entire point of using Docker and containers that they are completely self contained and have everything they need within them to function and communicate with each other?

Other than needing to initially install some dependencies for this to installation to function, i.e. Docker, Appamour, Network-manager etc, the operation between the supervisor and HA containers is completely isolated and not affected by the OS? Please correct me if I’m wrong.

Is it the changes in the dependencies that create the issue? If so, can they be brought into the Supervisor to prevent being changed or corrupted by the user?


Are you trying to run NUT in a docker container or use the NUT integration with HA Docker.

If it’s the latter try checking out my post here: Nut Sensor with docker

I just threw it on an old NUC because it was there. I’ve mainly run a vm in unraid in the past. I was curious about the experience because a lot of other users were using it. The NUC has a single SSD and I run two VMs on it at the most. One of them is HA. It would make sense to have more drives in a nice powerful tower where one is dedicated to the hypervisor and the others are for the VMs but it was not a requirement. It runs fine.

1 Like

If you are going to remove the ability to install on generic linux, can we please have a USB installer for HassOS? that way we can install the OS on generic hardware very easily.

reading the docs, it seems like you’re expected to always run off an SD card?

Overall, this is a very sad decision to hear, as a lot of pro uses (evident by the amount of comments) have far outgrown a rPi because of its performance tier, and installing HassOS on other hardware doesn’t seem straight forward.


Maybe as part of this someone should tidy up and make the official installation webpage more accurate and usable for installations. Any devices such as Pi 3B etc that fully supports USB and SSD boot should have the instructions about using an SD card removed and updated, as SD cards are many years obsolete in my opinion. Theres nothing on there at all about using an SSD or USB flash drive which is pretty poor i think considering the cost nowadays of SSD and USB flash drives. People new to home assistant and looking at the installation page are being mislead about the reliability of SD cards and are basically starting out with a ticking time bomb. Why not get those newcomers setup on reliable and solid platforms and not force them in troweling the forums for hours trying to work out how to install Home Assistant when they have little or no experience at anything to do with home assistant. I spent hours and hours initially trying to learn how to get my Pi booting with USB and raspbian searching through hundreds of posts all over the place and i cant see any reason why all the installation methods cant be pooled together on the official installation page now that a large proportion of installations have become unsupported. Listing it on the site as an option is one thing, but providing clear steps on how to install it is another.


We wait and hope that something good will come of Webthings Gateway

As a developer myself, I am all for protecting the health and sanity of developers creating open source software.

That being said, I don’t think this was handled well at all. It was already fully understood by me that any issues with the Supervised Generic Linux version of HA would require me to figure them out myself, that was already the case AFAIK, there were warnings all over about it not being the recommended way to run HA. You are making it sound like you used to provide support for this kind of setup, but if that’s the case, you certainly didn’t have to. But deprecating the whole installation method just so you don’t have to provide the support that you already didn’t have to provide? I don’t get it.

Additionally, the fact that you provided no notice at all means the community will now have to scramble to figure out a solution. Pascal’s health is important, but so is the health of the users who spend countless hours configuring and maintaining their home automation system on a platform that is suddenly, unexpectedly made obsolete.

I respect Pascal and Home Assistant and Nabu Casa, I am rooting for them to continue to provide the best home automation platform around, and I plan on staying subscribed to Nabu Casa to help support them. But this sucks…


I only recently got started with home assistant. I quickly outgrew the RPi. I ordered an HP Mini G2 last week. Supervised is the only thing that makes sense for decent hardware. I’m not going to have only home assistant running on my new hardware, which I would not have purchased had I known this was coming. Yes, home assistant is free and I should shut my trap, but a little notice would have been nice. I guess they want users to stick with RPi/SD Cards. Seems an odd direction to take. BTW I quickly subscribed to Nabu Casa so I am willing to pay - home assistant is awesome.


I am in the same boat as you… HA was getting slow, and my Pi was filling up, and I wanted to run other more demanding software on the same machine, so I set up a home server, spent the last several weeks getting it set up exactly how I want it and running great, and then the installation method is suddenly deprecated.

We’re not completely out of options, you can run a virtual machine within your HP Mini G2 and install hass.io within that. But it means rethinking things, and using more resources/adding more layers than should be necessary.


As someone who runs in this installation type I can say this.

I started with a pi and wanted to move to a more powerful homeassistant instance without having to to buy another $300+ machine to run it, or another vm instance on my primary machine, and with my config the pi was beginning to become pretty slow.

I had a dedicated Linux machine that I use for other tasks as well as docker so this type of installation was perfect. I subscribe to nabu casa just to support home assistant(and make Google Assistant integration easy). I’m sure there are plenty of sysadmins/smart home enthusiast like myself that use this method and also support the community as I do.

Using core, while it fits some people’s usage/time/skills, can be a chore (which nobody wants, or at least me!). Being able to have a full hassio install with update and addon capability without having to manage this manually has been a godsend. Many of us have very busy schedules and having to manually manage and configure our home automation platform (we still do but not too the extent core world require) consumes a fair amount of time. I use and contribute to a number of open source applications that are in my wheelhouse but docker and python aren’t part of that, hince the subscription.

I kindly ask that this be reconsidered. Personally I’ve never asked nor encountered an issue with this method and I imagine there’s many many more like myself.

TLDR: if this is just a don’t ask us for help but it’ll still work post, cool. If it’s a “we’re going to break things for people who run supervisor outside of hassio” post I’d ask you to please listen to the community and reconsidered.

I thank you and a hats off to all the devs who contribute!


I am running proxmox 5 (shame on me for not upgrading). It is a 4 year old nuc with only one SSD.
As many here, I am/was running HA supervised in a VM running debian (I like having access to a full OS just in case). After reading the blog entry and then finding whiskerz007’s script, I gave it a go on my proxmox host. Applied exactly what is here:
https://github.com/whiskerz007/proxmox_hassos_install and it works. As a Sunday test, I have switched off my hassio debian VM and now running on hassos VM. We shall see how it goes :slight_smile:


1 Like

HA Core in Docker and another container with Watchtower. Flawless, always up to date on any platform.

1 Like

I read this with dismay and felt like the rug had been pulled from under me because last weekend was spent setting up and installing HA Supervised on a dedicated machine has I felt this was my best option. I had considered proxmox but its expensive and I couldn’t justify it. While the reason given is understandabnle its a bit sudden.
I had been running HA on a PI4 but my setup had out grown it. Personally I fell that HA has out grown the raspberry pi (SDcards are also unreliable) and have heard others say the same thing.
I am hoping that the decision can be reconsidered.

Question, while I understand this won’t be an option (at present hopefully), will the HA instance I’m running be able to get updates, my understanding is that supervisor won’t.


I assume here that it is the supervisor which is getting deprecated and therefore users with “non supervised” linux installations should be fine? They should be much more similar to the linux venv ones with the venv being optional.

“expensive” in $ or €, no, there is a free version that I have been using for years. Flawlessly.
However, like all hypervisor, it will be more “expensive” in term of ressources that running natively on the hardware.


1 Like

I saw no free version when I checked the website