On OS 5.8/2020.12.6.Trying to install AppDaemon 4

After installation & starting AppDaemon4 i get these errors in the log-file.

I have googled & Youtubed the best i can but only get to that it should work without any change in the configuration at all. Another OS 5.8 thing or ?

I have tried uninstall/re-install several times with restart of OS in between, no change.

Happy cake day!
Do you have a /config/appdaemon/appdaemon.yaml file?

I have installed many other add-ons without any issues. As said in the text you attached: “The installation of this add-on is pretty straightforward and not different in comparison to installing any other Home Assistant add-on.”, it is easy to install, but it fails when checking the log as illustrated in the picture i attached of the log.

I tried to create a appdaemon.yaml in the appdaemon folder manually & filled in yaml i found from different examples on net but as shown in log it still doesnt find the appdaemon.yaml file at all.

I’m not using the addon (running HA in a venv), but tested the installation of the addon in my HA Play VM with OS 5.8/2020.12.7, and it started without problems.
Appdaemon folders and files are created without any issue.

Thanks for your try…I am not enough into Linux to dig much further myself. Just hoping at future update will take care of it or wait and see if anyone else suffers the same. Cant see why HA shouldnt have the privileges but they also forgot to remove some power-saving features in the OS 5.8 as my Chromebook kills network & bluetooth if i close the lid so hope there will be som fixes coming up :slight_smile: Thanks for your effort :slight_smile:


AppDaemon NEEDS an appdaemon.yaml with config in it to work. Im not 100% sure everything is needed but here is is my appdaemon.yaml placed : /config/appdaemon/appdaemon.yaml

threads: 10
app_dir: /config/appdaemon/apps
latitude: 5x.xxxxxxx
longitude: 9.xxxxxxx
elevation: 5
time_zone: Europe/Amsterdam
type: hass
ha_url: (change to yours)
api: Insert api here
token: Insert long lived token from Home Assistant here
dash_dir: /config/appdaemon/dashboards