One Router, Two SSID but HA Can't see my IoT SSID

HA noob here. I have searched and read similar posts about this but could not find an answer to my specific issue. If there is a thread, please link to it and feel free to lock this thread. Sorry in advance if that is the case.

Here is my issue:

I have one mesh router, TP-Link Deco AX3000, with two SSIDs configured – the main and a guest.

  • The guest network has all of my IoT devices that is named “Hub”
  • The main network has my laptops/computers/cellphones/TVs named “Smashed”.

The IoT “Hub” network is configured for only 2.4 and the other is 5.0.

I have a Pi3 with a fresh install of HA plugged via ethernet into one of the physical routers.

While HA can see everything on my main “Smashed” SSID, it can not see or access anything on the guest network that has all of my IoT devices. So I am stuck and basically can’t use HA. I looked through every setting and can’t find a solution.

Is there an easy fix for this? The other threads I read that are similar seem very involved and way out of my realm. I am not even sure if they are the same issues as mine. This is why I created this new thread.

I figured my issue must be common since most routers offer two networks and it seems having one for IoT is a common practice.

Thanks for any help. I really want to get this working. I have been bitten by the Smart Home bug!

This can only be answered with reference to your router and/or AP manual.

Thanks for the reply. Not sure what you mean though. Networking is the subject I am least knowledgeable on. If there is a setting I need to change on my router, I just need to know what that setting is. Nothing stood out to me that would help when I looked through all of my router settings but again, I am not overly knowledgeable with routers.

Neither am I, but at least you have the manual.

PS start with ping! Also this forum will be a good place to ask

Fair enough and thanks again. I looked at the router documentation and nothing in there talks about this issue or anything about HA. At least nothing that I could tell. Hopefully, someone has had this issue.

As said, I figured this was one of the most common issues someone would have. I can’t be the only one that has two network SSIDs on one router with one SSID containing all IoT devices. I set it up that way based on many, many people suggesting to set it up.

I feel embarrassed I can’t figure this one out!

Use vlan in your search terms. If this is a guest lan, then guests can’t usually contact your regular lan devices. When i used my isp’s access point/router there was a wifi setting for guest lans called “isolate” , which made each device only able to contact the internet, not your stuff on your lam.

Thanks, Not seeing that option in my router’s settings. The only option that sounds like it might do something is port forwarding. Though I have no clue how that works so I don’t want to mess with it.

Just wondering how others get past this.

Most consumer grade routers that offer a “Guest” WiFi network, do allow allow traffic between the Guest and regular LAN/WiFi network. The “Guest” networks were never designed for home automation devices, they were designed so that guests in your home could use the Internet, but not infect other devices in your home.

Thanks for taking the time to reply.

I am not having any luck even accessing my fresh install via my browser. It worked for 2 days and now when I try to go to it, I now get a ‘DNS_PROBE_POSSIBLE’ in the ‘site can’t be reached’ error.

It seems I am not off to a very good start with HA! Nothing is working now. The funny part is that I have been prepping and learning about HA for months now. I thought I was ready.

I should mention I didn’t change any settings or router settings. It just suddenly stopped working and cant be reached. Even after a fresh re-install. Not sure what is going on. I suck at this.

I would suggest you first start with a single, flat network before you try more complicated setups, to ensure there aren’t other issues.

With the info so far, it’s quite hard to offer any advice (not saying I’m an expert though).

For example, if you have defined two access points (APs, the things you named Smashed and Hub), are they using the same network range (subnet, in networking terms, e.g. Does your router specifically have a guest network feature, or did you just create the two APs yourself? It might be possible to set up some routing to connect the two subnets (VLANs). Then, device config: there will be a subnet mask (e.g. that will determine what is local to that network. Depending on your network config, that subnet config may need to be changed.

EDIT: Fixed subnet mask. Thanks @nickrout.

The first number there should 255. Typo I know, but we don’t need any more confusion.

1 Like

Thanks for your reply. My router offers two SSID (main and guest) and the ability to assign each a freq. I put all my IoT on the guess in the 2.4GHz. When I go into the settings, I only see one LAN IP with subnet

I have not touched any settings in my router since I set it up a few months ago.

As of right now, I can’t do much because I can’t even access the HA control. It gives me the site can’t be reached error with ‘DNS_PROBE_POSSIBLE’ . As said, I have not touched any settings. Not sure why I can’t access it now at all. I even did a re-install with the same result. I can’t access http://homeassistant.local:8123/ or via the IP address, it is located on.

I am 100% stuck and cant do anything. Is there something more I can do besides re-installing HA? I already tried that! I cant believe I am such a noob.

My Asus by default DOESN’T allow guest account to access internal network. Guest wifi has option “access intranet” - check if yours have anything similar - you must enable it.

Thanks for replying. My TP-Link Deco offers a guest network. See below for the only options it offers.

Also below is the error I now get when trying to access HA, even via direct IP.

On THIS page i’ve read this:


1. When Deco works in the Router mode, the guest network and main network
are isolated.

2. When Deco works in the AP mode, on the Deco app>More>Wi-Fi page, there is an
 "Isolated From Main Network" switch once the guest network is enabled and the 
switch is used to enable or disable the network isolation feature on the deco.

So, if your router works as “router” there’s nothing much you can do except turn off guest account and connect all devices to main wifi, but if you are in AP mode there must be an option mentioned.

I truly appreciate your help. Can I switch to AP mode? I saw that option originally when I set up my router but thought it was not right for my situation. My Deco connects to my ISP’s modem via ethernet.

So your modem is in fact main router? In that case i guess that you can, since it’s no use to have two routers one after another - such setup can cause problems, since two routers can assign IP (via DHCP service)…
But then there’s another question: whether it makes any sense to connect IOT devices to a separate wifi… if your IOT devices are connected only locally (you can’t reach them from outside so they can’t be broken in) then there’s not much difference if you connect them to guest wifi or to main wifi, since router almost certainly uses same radio for both wifi signals. So it’s not much difference in chip’s load.

But i’m not super skilled in networking, too, so maybe others will come up with any better (or more correct) solution. My ISP box acts only as modem (i asked them to) and my Asus RT-AX88 connects directly to public IP. IMy Asus is definitely a better router than ISP’s one, and most important it’s completely open for settings (ISP routers are usually pretty locked up and there’s not much you can do).

I have all my devices connected to main wifi, guest account is turned off. I wonder if it makes any sense to have two wifi accounts, which are then inter-connected anyway…

Good spot. If router 2 is connected to router 1 via router 2’s WAN port, it almost certainly is going to cause trouble, since router 2 won’t route out to router 1 (I’m fairly sure of this, since I’ve once had a similar situation to debug). So, if the browser is on a PC connected to router 2 and HA to router 1, it won’t find it.

Can you make a backup of your current router config and reset it? Then, reconfigure it from scratch. You can always restore the backup once you’ve figured out the issue. I really think you should start with a simpler setup until you have a better grasp over the networking (this is honest advice). I don’t think using a guest network (the specific feature on your router) is the best idea, because it will be restricted in some ways.

Did you choose the subnet of (or changed it at some point to it)?

I doubt the issue is HA here, so reinstalling HA is probably not going to help.

Also, exactly how many routers are involved here, and is there only one DHCP server?

Edit2: Sorry Prontoncek was ment at @eviltrance

Lets assume you know(find out !) the ip-number of your gateway, and it match the sub-net, you try to access HA, then you wan’t to be on the same subnet, otherwise you could get similar error-message as above, but as a " noob " i strongly suggest , reset your router to default settings, your problems is far from over, even when/if u get access to your HA, your haven’t provided any details regarding your network-setup(i assume your a “noob” there also)( we all been in any subject), but you start your “journey” by using a guest network, don’t … anyway, you should “google” such error’s as your are aware it’s not related to homeassistant at all, google is your best friend, when getting to know your “devices” and your manual , network setup, with “subnet” demands knowledge of network setup, dns resolv, routing etc. witch you have no understanding of (it seems), you will save alot time by resetting your router to default, set up your devices on 1 net, same as HA, disable guest for that matter(you can always enable it if you find use for), get to know HA and it’s(your) environment, eventually you can go towards subnetting
PS: guest network in routers is usually a subnet, separated from all other “internal” net, it has no value for, as you might as-well could have made a subnet your self( and you don’t loose this guestnetwork, it’s just a predefined subnet), most likely do you get DNS errors for same reason, and you can still “Choose” to ADD all your wifi device to 2.4(which they want) and you 5.0 for other device(but read about this also, specifications for 2.4 VS 5.0 and you will find, that the best option for all other device is to choose what ever they want … i.e. i have to switch my phone to 2.4, every time i need to add device etc to HA, for some reason my phone prefer 5.0(and i haven’t found any setting to change this), most likely factory-default, as most/ if not all “minor” wifi devices prefer 2.4 … and most new routers devices also have “intelligence” to decide witch “Band” is best

1 Like