Only 5 of 10 devices shown in Z-Wave Network Management node list


I have just over ten devices in my Z-Wave network, a few of them dead duplicates. To remove the dead and configure others I need to select them in the node list on HA’s Z-Wave Network Management page. (Right?) However, only five* devices are shown in that list.

The Z-Wave controller (RaZberry) is always listed, as well as node 4 (Fibaro Multi Sensor) and often the most recently added device.

What can I do to make all Z-Wave nodes selectable?


Prior work

* Not entirely sure if I haven’t seen six at some point, never the complete list though.

Please allow me to bump this once.
Is there any additional information I could provide to shed some light on this?

How do you know there is 10 if you only have 5 in the list?

The devices show up in the HA devices list and are controllable via Lovelace and the HomeKit bridge just as expected, e.g. they “work”.
Some just don’t appear in the Z-Wave setup area where I’d configure device specific options. (Apart from a few dead devices that I also cannot remove because I can’t select them in Z-Wave Network Management.)

If you aren’t getting a paired ‘dead’ zwave.xxxx entity inside your devtools/states page, then this has nothing to do with zwave. I remember reading in the past 2 weeks about a bug related to the device list showing old entities. I’d start by looking there. There are ways to edit those out, but it requires modifying the json configuration files in the hidden storage folder. I have not needed to do it myself.

Let’s ignore the dead devices for now, I already suspected that would be a separate issue.

About the zwave.* entities: I tend to disable all entities of a device in HA that I don’t actively use (unlike a light entity for example). So I also disabled the zwave entities - could that be related to this issue?
Re-enabling a zwave entity results in a greyed-out zwave icon and “This entity is not currently available.”.

[…insert elevator music and some fiddling around of mine here…]

Hooray! The greyed-out zwave entity is back to normal after restarting HA. And now the device where I re-enabled the zwave entity also shows up in the node list again. So you nudged me exactly towards the solution. Thanks, @petro! :+1:

The only thing I worry now: Shouldn’t this be considered a bug? Disabling entities for clarity should not break Z-Wave node management as I see things. Can I maybe help there? (Python knowledge at hand.)

Yes i think it would. If you have a surefire way to reproduce it, write up an issue on github.

This is the GitHub issue for future reference.