Open Z-wave 1.4 no longer supported ozw 1.8 in progress

I tried to move from zwave native to zwave2mqtt to fix some device issues, but z-wave2mqtt is default 1.4 ozw. The developer of ozw said he’s starting work on ozw1.8 and 1.4 isn’t supported anymore.

How can I get ozw1.6 working on home assistant? It’s been out for 12 months now and home assistant on the community installed versions via Lovelace or the native version all run on 1.4 which is no longer supported.

I’m running HA on raspberry pi and not sure how enable the latest-dev tag on zwave2mqtt to force it to run 1.6

Native OZW 1.6 support is being worked on, but it’s not a small upgrade.

I’ve seen nothing about OZW 1.8 - 1.6 is the current stable. The Z2M Git seems to suggest that they’re supporting 1.6.

I was in contact with the dev this morning via github, Ozw support in z2m. They are saying they won’t support 1.4, 1.6 is current and supported

Do you have a issue with ozw 1.4 that you need 1.6 or 1.8 to address ?
I realise that some network features will be supported like OTA firmware updates etc. but ALL of my current devices work flawlessly.
Or is this a matter on just getting the biggest number on the latest release ?

I have 2 fibaro walli dimmers that aren’t recognized. I can manually update them, but if the XML file corrupts then the manual config goes away. The secure thermostat doesn’t allow heat mode only set point on the temperature. This means manual override doesn’t work, also since 103, Google home doesn’t recognise if the thermostat is on heat mode. The boiler actuator doesn’t show switch state “on” when triggered by the thermostat, but if manually triggered it does since 103. There’s a bunch of other devices that don’t see the 3 endpoints and only see 2 endpoints, such as the fibaro dimmer 2 puck, it acts like a switch, not a dimmer. Don’t care about the version, just shit working correctly without needing to spend hours fixing non- functioning devices. I know for sure that the walli dimmer and the thermostat have definition files in 1.6 that aren’t added and will never be added into 1.4.

FYI, HA maintains a fork of 1.4 and it contains updated XML files and a few fixes that are not in upstream 1.4. Updated XML files are so far still being accepted, since 0.103.

If you’re talking about the Secure SRT321 (Horstmann HRT4-ZW), there is a bug in HA, which has a workaround/fix here.

I fixed the climate entity not showing from 103, but the heating mode doesn’t work with the fix. I can now remotely set the temperature from HA as a set point thermostat. Google home now always sees the thermostat as turned off though even when it is manually set to a higher temperature and is actively heating. The fibaro walli definition files are not in the HA maintained 1.4 repo, also the Aeon wall mote quad is only partially recognized and needs manually changing to make it work. The switches have to be manually edited to make them transmit a scene change that can ba auctioned in an automation.

It is possible to get 1.6 running with Zwave2MQTT but its a bit of work.
To give you some ideas, here is something I posted on another thread.

Can all these definition files be imported into tbe 1.4 repo?

The XML files are community provided, someone, preferably one that uses the devices and can test them, needs to add them. The HA devs are not going to do this…

Yes, this is one of those features that requires 1.6 so you’ll have to wait for that. You can manually add scene support with modified XML files though, for example.

I’m running on the raspberry pi with the standard image. What’s the best way to install it without it being on a full blown linux image?

Most of those are already supported by HA, you need to be more specific.

Someone recently submitted a FGS213 update.

If there’s something missing you need, you might have to take it into your own hands. Unfortunately that’s just how it is until 1.6 comes around.

How do I submit the updates? I’ve tested the ones I need by mainly editing the XML file after inclusion and the functionality works. I’ve got to add another 6 of the same device and don’t want to keep manually figuring everyone of them when in know they can be automatically included.

I specifically want to add this one

There is a guide here.

The good news is you don’t need to do much. The config file you want was already added, 3 days ago. In that case, the only thing preventing it from being added to HA is getting included in a release update.

But you don’t necessarily need to wait, you can download the current set of config files and use the config_path setting to reference the updated files.


Cool, thank you foot confirming. I’ll hang on for the addition to production, I guess it can’t be that long

The update to z-wave devices database didn’t make it into version 0.105.0 even though it was submitted weeks ago.

? Looks like 0.105.0 updated ha-pyozw to 0.1.8.

Yeah, the wrapper was updated, but when I refresh the nodes that weren’t correctly discovered they still aren’t discovered. You mentioned previously that the node type had been added to the known device config list. It appears that it didn’t work or get added :frowning:

I think you’d either need to Remove and re-Add the node, or delete the contents from the zwcfg*.xml file and let it get re-populated.