OpenAI Integration not working with Voice Assistant


today I tried to configure OpenAI with Voice Assistant, but I’m getting the following error message.

Sorry, I had a problem talking to OpenAI: Error code: 404 - {‘error’: {‘message’: ‘The model gpt-4o does not exist or you do not have access to it.’, ‘type’: ‘invalid_request_error’, ‘param’: None, ‘code’: ‘model_not_found’}}

Is there already a solution for this problem?

Have you set up an account with open AI and deposited funds?

Yes, I tried the free and the paid version.

I had the same issue. From my understanding, even if you have the pro subscription, you have to deposit funds and enable the auto charge. and it charges separately for API use. and you’ll want to set limits in case it goes crazy with calls. I’m not going through that though myself and I just disabled it all. I’m on pro but not paying separately for the same service. I have a localAI set up and I want to use that, so I’m just going to wait for a self hosted AI integration to come out. I don’t need all my calls going to a cloud service. AI or not, I think most of us are trying to move away from the cloud having data like this.

Got it, thanks! I also don’t want to pay own top of my pro subscription for this. Really annoying…