OpenGarage - open-source Wifi garage opener

Quick question does 1 sensor do a standard 2 car garage or would you need two sensors? Double garage door not two singles.


Each unit controls a door so you can use it to control the single door.

Ok that I figured but a 2 car garage with 1 door would require two units to monitor if the car was in each spot of the garage. but only 1 would control the opening and closing of the door. Or do the sensors have a slight tilt to cover both parking spots.

See image might make more sense, or instead of having it in the middle do you need one above each car.

You really can’t use the sensor for the car - it would just be for the door status.

Is there any way to adjust the timeout period for this component?

I have two OpenGarage devices and I get a couple dozen of the warnings in my log every day from each device:

2017-11-11 10:53:17 WARNING (MainThread) [homeassistant.helpers.entity] Update of cover.subaru is taking over 10 seconds
2017-11-11 10:53:17 ERROR (SyncWorker_1) [homeassistant.components.cover.opengarage] Unable to connect to OpenGarage device: HTTPConnectionPool(host='', port=80): Max retries exceeded with url: /jc (Caused by ConnectTimeoutError(<urllib3.connection.HTTPConnection object at 0x2b15bff403c8>, 'Connection to timed out. (connect timeout=10)'))

This causes the state of the cover to go to ‘unknown’. It always recovers after a few seconds so I’m thinking if I could increase the timeout to 20 or 30 seconds I wouldn’t have this issue any more.

The 10 sec timeout is in the code, and not a setting you can configure. You could open the component python src and change it if you want. Honestly, 10 secs is a long time for a device that’s on your LAN. You must have poor wifi coverage in your garage.

Yeh, 10 secs is a long time but the wifi coverage is actually really good. I’ve got an AP right above the garage.

My OpenGarage devices are definitely having some sort of network connectivity issue though. If I get a continuous ping going to both of them, they’ll drop a couple pings every couple of minutes. What’s interesting is that they almost always both drop at the same time. I’ve also got a Bruh multisensor in the garage (also built on a NodeMCU) and it does not do this.

These dropped pings don’t always correspond to Warnings in the HA log…but I got to assume the issues are related. That’s too bad about the timeout period. I was hoping that it would be an easy workaround.

I was thinking that maybe the polling intensity from HA might be too aggressive for these little boards but I doubt that is the case.

I have the same issue, It is working untill the power goes, won’t come back online unless I disconnect the relay.
Did you solve this? How?

I am having this same sort of issue. Wondering if anyone has found a solution. I can’t program any automations on my garage door cover state since it keeps coming and going.


I noticed yesterday when I built mine, that if the distance is to far the sensor jumps up and down in registered length.

check the devices website to see if you have a stable distance shown or if it jumps.

I have no clue to solve this yet.

So I sat around watching the cover in the dev tab of hass and noticed it is switching to the following:

Note the door_state is set to offline. Seems like a connectivity issue or perhaps a response issue upon querying opengarage from hass. It seems the issue is that when hass gets an offline reponse from opengarage it labels the cover as open. To me this seems like a bug, my expectations would be that if opengarage did not give a response (it is offline) then keep the current state until the next attempt to get the state from opengarage.

Wow. Mine is not quite that bad. If you get a continuous ping going to your OpenGarage, does yours drop pings every couple of minutes?

Mine does. I can’t figure out why. And when HA can’t poll it for 10 seconds, the status gets marked as ‘unknown’.

I never did solve this :frowning:

What about adding a second distance sensor. Playing around with the OG code, the API would look something like …

{"dist":227,"dist2":227,"door":0,"vehicle":0,"vehicle2":0,"rcnt":20,"fwv":106,"name":"My OpenGarage","mac":"5C:CF:7F:17:55:E9","cid":1529321,"rssi":-61}

I think we can test if dist2 existed and it would not be a breaking change and would work with previous OG versions.

Hey, I am still waiting for my relay to arrive its on a row boat from china judging by the speed of the postal service :). Although my program skills are lacking to I don’t have any I am willing to test or try out I bought 2 sets of gear.

Well that explains why that boat from China is slow.:rofl:
I too am waiting for parts, but I had a developer board and HC-SR04 laying around for different reasons. I wanted to use the HC-SR04 with a PI Zero for car presence sensing. After finally giving up on GoControl zwave, I found this thread. Big thanks to @swbradshaw. It got me past the OZW issue and had car detection. Now all it needs is the second car. So I pulled out the ESP8266 Dev board (that has been laying around for over year) and started learning. I started working with Jeff Lawrence
( His code was just merged into the OG, so it’s a good base to start with. The post above is my suggestion for the response change. I have never develop HASS components, but looking at the OG cover, I don’t think adding the second vehicle will be that hard.
Right now I am working with a hello world trying to get 2 HC-SR04 in 3 wire mode. Trying to save pins on the ESP8266. I tied sharing the trigger, and got some flaky results. Not sure if the issue is the closeness of the sensors and sound transmitter interfering or not enough current on the pin to drive two triggers. I want to be backward compatible with OG hardware and make it a simple hack for someone to added a second sensor. Well see how all that goes. Once that is all worked out and I know what parameters will be needed (to keep backward compatible) I will be back.
Discussion I started on the OG forum

I turned down the transmit power on my AP a couple days ago and the issue of the OG devices losing network connectivity and timing out in HA seems to have gone away.

@alfi33 what exactly do you mean by power on the AP? I don’t really follow. Thanks

@nalipaz most wireless access points and routers have the option to adjust the transmit power of the wireless radio. I use Ubiquiti APs in my home and I lowered the transmit power for the 2.4GHz radio to medium. I was trying to fix an entirely different problem when I made this change…but this seems to have fixed the connectivity issue I was having with my OG devices by happy accident. My OG devices are really close to my AP…so I guess the signal strength was so strong for them that it was causing some sort of an issue.

This may not be at all related to the issue you’re having, but I thought I’d mention it just in case.

To everyone who has built their own device what box did you house it in?