OpenWeatherMap integration - how to change zip code?

I added the OpenWeatherMap integration to home assistant, and I was able to put a card down on the lovelace UI. But maybe I entered the wrong location information via the GUI when I first configured the integration, because the forecast seems wrong.

It seems I should just be able to go into the configuartion>integrations>OpenWeatherMap and re-configure the location, but it’s not an option. In the OWM integration docs, there’s some parameters for setting API key, LAT and LONG, it doesn’t actually list an example of what to put in the configuration.yaml to set it up manually. I know I can’t just willy nelly put “Latitude” anywhere in the yaml and expect it to work. A simple example, just like 6 lines, would do worlds of good for newbies.

image

List parameters for configuration.yaml, but no example.

2 Likes

It’s only configured in the UI. Delete the integration and add it again.

Still this way, and still quite lame; no way to verify which API key you are using, etc. Need to be able to edit all the setup parameters… must be quite a pain for those trying to debug their setup (add, delete, add, delete, add, delete, etc)

2 Likes