OpenWRT/LUCI Reporting Stale ARP Entries

This isn’t, strictly speaking, a HA question, but I was hoping that other people might have experienced the problem I’m having and be able to suggest a solution.

My OpenWRT router is still reporting a device (a friend’s phone) that left the network over 24 hours ago in its ARP table, so the luci device tracker is still reporting that device as home. The arp command on the router doesn’t support any of the usual options, including -d that you would normally use to do this.

Does anyone know how I can get my router to clear that entry out of its cache?

Hey did you ever figure this out?

I have a similar problem.
in my routers arp table some of my devices are listed over eth0 and alsways as present instead of br-lan.

a “simple” solution should be to add an optional parameter to the luci device detection plugin:
the interface which is related :wink:

simple solution for my problem:
i set a cron job on my router, which starts:
“ip -s -s neigh flush all” every 5 minutes