OpenZwave (beta) integration stuck at Network Starting, Initializing the Z-Wave controller

I’m trying to debug an issue with OZW. I’m using OZWDaemon 0.1.176 (OpenZWave 1.6.1392) running in docker. HA is stuck on initializing. The integration’s config page shows “Initializing the Z-Wave controller”.

None of the entities are enabled in HA. They are marked unavailable.

I can subscribe to the OZW MQTT topic (OpenZWave/#’) and the z-wave network appears healthy based on these messages.

There is nothing in any of the logs indicating why it is stuck initializing.

Any other suggestions where to look or use additional tracing?


What happens if you call the mqtt.dump service?

Unfortunately I (just now) managed to fix it :slight_smile:

In the ozwcache_*.xml file there was a node id=“0”. It seems I somehow failed to complete an add node? Not sure how that was created, but I was adding a motion sensor at some point before this started.

I deleted that node element from ozwcache_*.xml and OZW was able to complete initialization.

Thanks for your suggestion regarding the mqtt.dump. I’ll add that to my list of things to use for diagnosis.

Where is that file ozwcache_*.xml? I’m having the same issue and I can’t figure out where the Open Z-Wave integration’s files live. I have SSH access.

I run both HA and OZW in Docker. The OZW config directory is a volume mapped in my environment for /opt/ozw/config.
Look for the latest file in /opt/ozw/config equivalent in your environment.

I’m wondering though if backing that file up and removing from that directory does the same? I didn’t test that (or look at code for ideas). This could simply be a corrupt cache issue.

Hey! I have the same problem but just cannot find the cache file. Im using hassos, so where is it typically stored in the docker-jungle?


Sorry, I’m not familiar enough with hassos – I started using the HA Docker image (homeassistant/home-assistant:stable) from the start.

BTW, try going to Developer Tools / Services / mqtt.dump and press Call Service with these parameters:

topic: 'OpenZWave/#'
duration: 5

Perhaps that will rebuild the cache correctly, although I never tried it.