OpenZWave (beta): Linear GD00z-4's switch not recognized

I have a Linear GD00Z-4 Garage Door Opener Remote Controller that I’ve added to my Z-Wave controller (Aeotec Z-Stick Gen5) using the OpenZwave (beta). Both Home Assistant and OZW-Admin app is reporting the device correctly as GD00Z-4 but I’m not able to control it. Under the Entities, all I see is the binary sensor for whether the garage door is open or closed. I’m unable to actually control it. I have tried adding it and remove it as a secure and non-secure nodes as well without any luck.
Is this just a limitation of OpenZwave being in beta at the moment or is there something else that I’m missing here?

I would appreciate any help you can provide. thank you! :slight_smile:

Double check that your network key is configured. The ozwdaemon log file will clearly state if the key was configured or not. The behavior you describe sounds like it was included non-securely. Barrier operation requires secure inclusion. The OZW Beta supports garage door openers.

I’d recommend excluding it, factory resetting it, and then securely adding it again.
When you add it, have the Linear device close to the hub and let it sit for a few minutes. I know my locks were finicky like this and they had to talk for awhile to determine all of the abilities. Then move into location and restart OZWD or heal the network.

Been trying to add it securely via the Aeotec stick, OpenZwave Admin app, and also via the HA.
When I add it via OpenZWave admin app, it says network key not set even though I did set it via HA using the OpenZWave add-on.

I then tried directly via HA but can’t get it to add using ozw.add_node

What is the correct syntax for adding nodes securely?
Documentation suggest using ozw.add_node and passing in secure attribute but what is a valid value for that?
Are any of these valid values?

Thank you!

"secure": true
"secure": "on"
"secure": "true"