OpenZwave Setup - Can't See Added Devices

Tags: #<Tag:0x00007f73951d2d28>

Hoping for a bit of help here. New to OpenZWave (and zwave in general). I can’t see added devices anywhere in HA.
Running HA Supervised in Docker on Ubuntu server.

What I’ve done:

  • Installed Mosquitto broker add-on (default config)
  • Installed MQTT Integration
  • Installed OpenZWave add-on (only added to config /dev/serial/by-id/usb-0658_0200-if00)
  • Installed OpenZWave Integration

Just trying to get a basic network up. Adding 1 device (Inovelli Red switch) for now. Pairing process went well (I think?). I called Developer Tools / Services ozw.add_node and hit the pair include on the switch, which flashed green indicating it paired. But I can’t see this device/entity anywhere in HA? Rebooted a few times…

In Devices, I can see my Aeotec stick with the integration OpenZWave. On my OpenZWave panel, at the top I see “Connected (unencrypted) to Qt for Embedded Linux VNC Server” and it just gives me a Open window with options for Local Client or Remote OZWDaemon. The drop downs on Local Client for Serial Port are TTYACM0 and TTYACM1. When I select TTYACM1 (which I believe is my Aeotec) and hit “Start” it just says “Disconnected”. Both mosquitto and zwave docker containers are up and running.

I’m sure I’m doing something dumb and noobish… Would appreciate help. I have 10 of these Inovelli’s to install, and got hung up on the first one!

I know pretty much nothing about troubleshooting OZW right now since I haven’t switched over (tho I’ve dabbled a bit) but just to see what is going on in the background I would suggest intalling an MQTT sniffer program. I use MQTT Explorer for stuff like this where I want to see all the traffic thats going on thru the broker. I also recommend MQTTFx for it’s ability to subscribe and publish to specific topics. And if you ever get into other uses of MQTT then they are great tools in your toolbox.

Then once you get MQTT explorer installed and connected to your broker you can see all of the topics that the broker sees. In there you should see references to “openzwave” and it’s subtopics and payloads:

If you don’t see anything there then it’s the MQTT or OZW base config that’s the issue. If you see the topics there you know it’s the HA side of things that’s the problem.

Thanks, this helped. I received the same feedback over on the Discord. While I don’t exactly know what I’m looking at in all this, it did help me to see that my switch did not finish loading. I had to exclude and include again, which seemed to have worked. The 2nd switch I tried needed to do that routine 3 times for some reason before it took…