OpenZWave - wrong status in Home Assistant

I reinstalled my home assistant, reset all my z-wave devices and z-wave stick.

I then readded all devices but this time using the openzwave beta integration.

The problem is that the status of the device isent always reflected correct in Home assistant.


The light is turned off, but the device is turned on in Home Assistant, if i turn it off it turns on again after about 1sec.


If i check status in OpenZWave gui the device status is correct. The device is off.!

When I turn the device off in home assistant, the message is received and aknoleged on my mqtt broker.:


If i quickly (before the device automatic in home assitant is on state again) turn on the device then the mqtt state is again received and the devices turns on.

I can then (if i am lucky) try to turn on the device again and then the state will be correct both in openzwave and home assistant


Logs arrent telling anything, any idear how to debug this, and find the issuie?

1 Like

What brand and model device is this?

The Z-wave stick is a Aeotec

The device (i see it on all my devices) is fibaro double switch, fibaro smart plug, fibaro dimmer

You might need to enable polling if the devices don’t support instant status/instant report.

But isn’t polling related to the end z-wave device sending status backup to openzwave?

The problem here is that the status is correct in openzwave gui, it just wrong in home assistant

Verify a difference between ozw-admin and the data as shown in MQTT. If there is you can report a bug to qt-openzwave, otherwise this will need to be reported as a HA core bug.

I have the same problem with random devices since installing ozw beta.

Polling is will show the correct status after a while but will not solve the root cause to the problem.


Same here, exact same problems as described above as well. I’m running all the latest integrations and Home Assistant versions with an Aeotec Z-wave stick and Fibaro dimmers. I don’t want to use polling as the zwave status is already correctly displayed in OZW-admin so checking the Z-wave device isn’t necessary and will create latency on the mesh network.

This is simply the HA interface not reflecting the correct status of the MQTT / Z-wave devices. Did anyone find a solution for this since it’s happening so often it’s making my entire automations unreliable.

  • Home Assistant OS 5.10
  • HA Core-2021.1.5
  • OpenZWave 1.6.1710
  • Aeotec Z-Wave USBS Stick
  • Fibaro FGD212 Dimmer 2

I still have the same problem.

Same here. No Update from states

I got it fixed.
Had many of my sensors added as secure devices, removed those and readded them as insecure devices. No only my fibaro (cant be added insecure) and my locks are secure added.

Delay is now under 1 sec and status is now working perfect again.

I eventually migrated to ZwaveJS and never had the problem again. Seems to be an issue with the outdated OZW integration.