Optimizing old laptop for HA server use

I use the laptop as a headless server - it’s hidden in a corner of an occasionally used room. One of the reasons for my runaway from Hassio was Samba, or better say, the impossibility of sharing the config location via NFS. As I said earlier, I use Linux as my daily driver and therefore I strongly prefer NFS over Samba for many reasons. Samba just sucks in comparison :-). If I need a direct access there is always ssh.

1 Like

When you use SSH, Samba, etc you can interface with your server right from another computer’s GUI, so you skip right passed the GUI of the server computer. This has a couple benefits: 1) better user experience (for you) because you’re using the local windows and programs of the computer you’re physically using, instead of looking at a video of the desktop of your server and 2) because you’re not using the GUI on your server, you uninstall it so it doesn’t use resources. Idk how much it’s using on your laptop but the default desktop on a raspberry pi uses quite a bit.

Sorry I hope that wasn’t condescending, I have no idea of your knowledge level.

1 Like

You already said it works pretty well, so haven’t you already answered your own question?

Having said that, upgrading to an ssd is likely a good upgrade. RAM is often an expensive upgrade on laptops, especially if the latest ram chips (which are generally cheapest) are incompatible.

1 Like

i have a old laptop in which only 32 bit ubantu can be installed ,
can i use it for Hassio ?

which version of ubantu server should i install ?
all the latest version of ubantu servers are 64bit only , so should i use older 32 bit version or latest minimal version ?

That would have to be really old! What processor does it have?

16.04.6 LTS is old, but I think it is the last 32-bit version. It is still technically supported, I believe.
I would tend to use Debian anyway without any desktop GUI. you should be able to use CLI & ssh for access. They still have 32-bit builds.

How do you run calibre-server exactly? I am guessing you are not running it inside of Home Assistant. Do you know of a good tutorial to install it? Thank you so much!


Here is my docker-compose calibre part:

##### C A L I B R E - W E B  #####

    image: linuxserver/calibre-web
    container_name: calibre-web
      - PUID=1000
      - PGID=1000
      - TZ=Europe/Prague
      - /home/vlad/docker_files/calibre:/config
      - /home/vlad/knihovna:/books
      - 8050:8083
    restart: unless-stopped

Sorry for the delay.

Hi @tom_l ,

An old post, but I have a Lenovo Q180 that had upgraded to Windows 10 but couldnt keep up, so I thought that I would repurpose it to a dedicatd HomeAssistant server. So i took out the HDD and wrote the “hassos_intel-nuc-5.13.img” to the HDD using BalenaEtcher. Not sure if that was the correct way. But now when I try to boot the PC I get the message “reboot and select proper boot device or insert boot media in selected boot device ad press a key” so obviously I didn’t do something correctly.

I have spent the whole day trying different things and following old tutorials but nothing seems to work. I tried to install Debian using thi tutorial byt get the same error after removing the boot installation media and try to restart the machine (Installing Home Assistant Supervised on Debian 10) so I wonder if you could clarify with me how to go about this to be able to reuse my old Lenovo Q180 for HA?

Thank you for any guidance from yourself or anyone else that can help.


Install debian, then do a supervised install.

The NUC images are for specific NUC hardware.

1 Like

Thanx @nickrout, if only it were that easy :0

Another 8 hours trying to install Debian lol… still trying 5 tries later.

Debian has support channels, but installing linux is usually as easy as pie.

1 Like

I’m going to add my experiences to this post (ongoing).

I want to speed up HA reboot and ESPHome compile times from my rpi4 4GB w microSD.

I have an old laptop with HDD and 4GB RAM which was destined for the trash. Battery failed long ago.
CPU is Intel i7-3610QM CPU @ 2.30GHz.

Before investing in SSD and memory upgrades, I decided to pull out the HDD, throw it in an external enclosure I have, and flash the generic-x86-64 image to it to see if it would work. I followed the instructions, and had to do the step to add a new EFI entry in bios (no clue, but worked through it), and now Windows is gone and HA is up and running the show. Was relatively easy.

Need to do some more testing.

Investigating removing screen entirely if screen-off no longer works. That’s fine for me.
Like this. Convert a broken Laptop into a Desktop - YouTube

Edit 1: Looks like the screen might always be on now.
Edit 1.1 Hang on no it’s ok. Maybe I didn’t check properly somehow.

Power consumption of laptop is ~ 27 watts with the screen on.
And ~ 22 Watts with the screen off (Lid closed)

I think my full loaded/operational rpi4 consumes ~ 7 Watts (using the same cheap smart plug with power monitoring). Not sure what the “zero values” are all about.

So I’m calling that four times more power consumption for the laptop…

Edit 2: Ordered upgrades.
Adding 8GB will bring it up to 12GB.
About $100AUD.

Initial upgrade resource usage:
Can anyone pick where I cut over;)

You should have upgraded the HDD to SSD years ago. I use a laptop like that on a daily basis and since I have it the first two things what I did was changing the HDD to SSD and the 8GB RAM to 16GB. Still no complaints, but it is slowly time to get a newer one and might re-purpose it as you did.

If you close the lid, the screen doesn’t turn off?

No I shouldn’t have. I’ve had no use for it and haven’t used it for at least 5 years. So no point in upgrading it;)

That’s right with the lid. I believe power management gets handed over to the OS during boot. And since Windows is gone and HA doesn’t manage the screen, it stays on.

That is pretty annoying. Look at this, otherwise I would open a feature request:

Thanks, yes I did see that thread. Might try some of the options out of curiousity while I’m waiting for my upgrades to arrive.

But tbh I’m warming more on the idea of totally removing the screen. Don’t think I’ll have much use for it. Might just double check if bios screens can be seen/accessed if I plug in an external one. I read that it might only be visible on the primary built in display. Probably don’t need bios access but you never know.

1 Like

Hi Morten, how you succeed to install HA on the Acer 3810t. I have one at home and I tried installing the Home Assistant OS ( Generic x86-64)on the Acer HD through Balena Etcher (HD temporary connected to a desktop PC via USB Sata adapter) but when I install back the HD in the Acer it state there is no OS installed. I thought it was a BIOS issue.
Any thing I’m missing?

I installed Ubuntu on it and then I installed HA in docker. It worked fine, but I ended scrapping the project as it used too much power with too little gain compared to a RPI.